Warning about PostgresSQL version while installing


#1

I’m new to SciDB, and attempting to install version 13.12 on a Ubuntu 12.04 64-bit virtual machine (running on VMWare Fusion), for simple evaluation purposes. I’m following the user guide scidb-userguide-13.12.pdf. In section “2.3.1. Install SciDB on Ubuntu from binary package”, during the install command (sudo apt-get install scidb-13.12-all-coord), I’m getting the warning shown below. Should I just ignore? Sorry if this has been answered here–I didn’t found mention of it in the user guide, and this forum won’t allow searches on “postgresql”, “database”, “cluster”, “8.4”, or “9.1” (…which makes finding answers quite difficult!).

Thanks.

[quote]Configuring postgresql-common

Obsolete major version 8.4

The PostgreSQL version 8.4 is obsolete, but the server or client packages
are still installed. Please install the latest packages (postgresql-9.1
and postgresql-client-9.1) and upgrade the existing clusters with
pg_upgradecluster (see manpage).

Please be aware that the installation of postgresql-9.1 will
automatically create a default cluster 9.1/main. If you want to upgrade
the 8.4/main cluster, you need to remove the already existing 9.1 cluster
(pg_dropcluster --stop 9.1 main, see manpage for details).

The old server and client packages are no longer supported. After the
existing clusters are upgraded, the postgresql-8.4 and
postgresql-client-8.4 packages should be removed.

Please see /usr/share/doc/postgresql-common/README.Debian.gz for details. [/quote]


#2

Ignore the warnings for now. As of 14.3, we’re still wedded to Postgres 8.4.

One of the goals for 14.6 is to upgrade the Postgres support to 9.3. Watch this space!


#3

Will do, thanks, and thanks for the quick reply!


#4

I thought one of the future goals was to eliminate Postgres entirely?


#5

It is. Getting from Postgres 8.4 to 9.3 is a purely tactical move on our part motivated by short term considerations.

The “work-to-upgrade-Postgres-8.4-to-9.3” << “work-to-eliminate-postgres”, while “priority-of-eliminating-postgres” << “priority-of-many-many-other-things”.

We’ve got similar issues to the OP. It’s a pain to drag around legacy Postgres in the toolchain, and the pain of doing so now exceeds the pain of the upgrade (which is mostly a re-compile w/ a new library, fix a couple of Postgres API calls, and write a script to get customers / users from 8.4 to 9.3).