V14.7 prepare chroot problems


#1

Hi, thanks for the 14.7!
Was trying a source build according to the insructions. prepare toolchain completed well, but prepare chroot had issues initially. It aborted because of a missing file.
For some reason, there is no /etc/mock/centos-6-x86_64.cfg after prepare toolchain, which seems to have yum installed mock in the first place.
So I tried the obvious, found that there is a default.cfg which points to something, and I linked centos-6-x86_64.cfg to the same thing. In /etc/mock:

lrwxrwxrwx. 1 root root 17 Aug 3 09:44 centos-6-x86_64.cfg -> epel-6-x86_64.cfg lrwxrwxrwx. 1 root root 17 Aug 3 09:29 default.cfg -> epel-6-x86_64.cfg
After making this link, prepare_chroot worked! Now I am waiting for make to finish, seems to be chugging along quite nicely…
If there is a default.cfg already, why not use it instead of looking for the OS-specifig named cfg file?

I don’t know why /etc/mock didn’t have the proper config file, I’d like to know if anyone else had this issue. All the config filenames in /etc/mock are epel* or fedora* where most fedora* files are symlinks to similarly patterned epel* files. I suppose this may be reasonable considering the strong ties to centos. But a rose by any other name is no longer a rose in this case :smile:

George


#2

make finished, but ./run.py make_packages /tmp/packages failed:

[code][scidb@localhost scidbtrunk]$ ./run.py make_packages /tmp/packages
WARNING: about to delete all contents of /tmp/packages/* [y]|n: y
Source path: /develop/scidb-14.7.0.7793
Script common path: /develop/scidb-14.7.0.7793/deployment/common
Build path: /develop/scidb-14.7.0.7793/stage/build
SciDB version: 14.7
Executing: build_fast /tmp/packages

/develop/scidb-14.7.0.7793 /develop/scidb-14.7.0.7793/stage/build
Extracting version
Extracting revision from file.
/develop/scidb-14.7.0.7793/stage/build
Version: 14.7.0
Revision: 7793
Preparing result dir
Cleaning old files from /develop/scidb-14.7.0.7793/stage/build
Preparing sources from /develop/scidb-14.7.0.7793 to /develop/scidb-14.7.0.7793/stage/build
Building binary packages insource
error: Failed build dependencies:
log4cxx-devel = 0.10.0-1 is needed by scidb-14.7-0-7793.x86_64
rpmbuild failed
./run.py: ERROR: Command make_packages failed: Abnormal return code: 1 on command [’/develop/scidb-14.7.0.7793/deployment/deploy.sh’, ‘build_fast’, ‘/tmp/packages’]
Make sure commands setup,make,install,start are performed (in that order) before stop,stopForce,tests
[scidb@localhost scidbtrunk]$
[/code]
Yes, log4cxx was installed. When I asked, it said, Package log4cxx-devel-0.10.0-13.el6.x86_64 already installed and latest version
Any quick fixes?
Thx, George


#3

BTW did the exercise in a local (not cluster) development conext using /usr/local/scidb as SCIDB_INSTALL_PATH and it works perfectly!
For the cluster problems, I think I wait until an expert can tell me what I did wrong :smile:

George


#4

Just change the:
log4cxx-devel = 0.10.0-1

in the scidb.spec.in file to:
log4cxx-devel >= 0.10.0-1

Works fine.