Ubuntu 12.04 - ERROR: Failed to start SciDB 14.8


#1

Hi SciDB Forum,

I’m having difficulty getting SciDB running - I’m a new user and continue to get the following error,

/opt/scidb/14.8/bin/scidb.py: ERROR: Failed to start SciDB!

I’ve followed the installation instructions from https://github.com/Paradigm4/deployment on two different machines, both running Ubuntu 12.04. The config file was generated using the configurator and the output is below. I’ve tried a few different configurations, including the samples that get installed, and still getting the same error. I’ve also check the environment variables to see that they are getting correctly sourced.

[mycluster]
server-0=192.168.100.201,0
install_root=/opt/scidb/14.8
metadata=/opt/scidb/14.8/share/scidb/meta.sql
pluginsdir=/opt/scidb/14.8/lib/scidb/plugins
logconf=/opt/scidb/14.8/share/scidb/log4cxx.properties
db_user=pguser
db_passwd=pguserpwd
base-port=1239
base-path=/home/scidb/scidb_data
redundancy=0
mem-array-threshold=676
smgr-cache-size=676
merge-sort-buffer=338
network-buffer=338
execution-threads=2
result-prefetch-threads=2
result-prefetch-queue-size=1
operator-threads=1

I haven’t been able to locate any log files that offer hints to what might be going on, any help would be much appreciated…


#2

Turns our everything is working fine. Did a fresh build, installed stash and saw that the instances were up and running. Still getting the “Failed to start” error, but stopping and starting again can get rid of it. Thanks!


#3

When the instances are started then an iquery is made to each to check for “liveness”.
The failure you are getting sounds like the instances start but the query fails.

By chance does your /etc/hosts file have 2 entries for “localhost”? one for ipv4 and another for ipv6 ?
I’ve seen iquery get confused with that. If so delete the ipv6 localhost definition.