Trouble installing shim


#1

I would like to have a local scidb and shim running on my Ubuntu vm in virtualbox.

I was able to follow instructions for installing scidb 15.7 on ubuntu 14.04, following build instructions provided here.

Steps I did different from instructions are:

  1. I only have hostIP0 which is 127.0.0.1

  2. scidbtrunk is at /home/usrname/Documents/scidbtrunk

  3. Enabled root access for ssh with changing the line

    PermitRootLogin without-password
    to

    PermitRootLogin yes

in /etc/ssh/sshd_config file

This worked and I was able to run an iquery session.

Then, I wanted to run shim Non-dev-tools using instructions at shim github page.

I ran the command

sudo gdebi ubuntu_14.04_shim_15.7_amd64.deb

but I got cannot load libscidbclient.so libraries error.

At that point I thought maybe building shim would be a better thing. But the shim instructions say

make sure to install SciDB at /opt/scidb

But by default, install location was

<dev_dir>/scidbtrunk/stage/install

So, I started over, followed build instructions and changed the SCIDB_INSTALL_PATH to /opt/scidb. Then I got an error during building scidb. After reading the build instructions again, I saw the note

but it[SCIDB_INSTALL_PATH] must be different from /opt/scidb/$SCIDB_VER

I am pretty confused and I don’t know how to make shim running at this point.

Please help.


#2

Hi! Sorry about the trouble.

Shim can be made to work either way - you just need to set LD_LIBRARY_PATH to include the location of libscidbclient.so (which is usually under $SCIDB_INSTALL/lib). That thing needs to be set before you start shim. If you want to start shim automatically as a service, you may need to make some changes to the shim config file and the init.d scripts that start shim.

Since you already started installing at /opt/scidb - note that the SciDB build instructions document (from http://forum.paradigm4.com/t/release-15-7/843) talks about two possible ways to install. Check out section 7.2 Cluster Development - perhaps misnamed - bottom of page 7. That’s what you do to put SciDB under /opt. This help?


#3

Thank you. I guess it is not possible to run shim in local development of scidb. I’ll try your suggestion.


#4

I’m pretty sure it can be made to work regardless of where SciDB lives-- just need to edit
/etc/init.d/shimsvc

  • you can see there is logic there that tries to set LD_LIBRARY_PATH and tries to “find” where SciDB is installed.
    In either case, you may already be closer to the other solution. Let us know if we can help with anything else!

#5

I changed LD_LIBRARY_PATH to $SCIDB_INSTALL/lib and I am still getting the same error, cannot find libscidbclient.so

Is it possible for you to provide me an ubuntu vm that has a clean scidb installed and running properly with shim?

best, bill


#6

The timing is a bit off right now - folks are working to release 15.12 and our plan is to make some public-facing 15.12 VMs very soon after that (i.e. in two weeks).

Meanwhile I just gave another friend of ours a 15.7 VMWare Fusion image with some demo data. It’s a bit large - 10GB compressed / 30 uncompressed. It’d be easy for me to give you that as well. Do you think this would work for you?


#7

Sure, I would like to try that.


#8

Ok, give these a try:
https://drive.google.com/open?id=0B7yt0n33Us0rUXQ2S0szMmZEeDQ
There’s an uncompressed vmware image (which turned out to be a whole directory) and a compressed .zip file. They are the same thing - it’s just that someone else had trouble opening up the zip file.

Let me know how these work for you.


#9

Thanks, downloading now. I’ll give it a try and let you know how it goes.


#10

What is the password for vm?


#11

Oops! Sorry :smile:

username: scidb
password: paradigm4


#12

Thank you it works like a charm!