Shim installed from .deb (15.7) doesn't work properly


#1

After Install Scidb 15.7, for using Rstudio, I installed shim but, It doesn’t work properly.

First, I downloaded and installed ubuntu_14.04_shim_15.7_amd64.deb from https://github.com/Paradigm4/shim

$> sudo dpkg -i ubuntu_14.04_shim_15.7_amd64.deb
(Reading database … 235384 files and directories currently installed.)
Preparing to unpack ubuntu_14.04_shim_15.7_amd64.deb …
Stopping shim
Couldn’t kill process 11224 (privilege error?)
Removing any system startup links for /etc/init.d/shimsvc …
/etc/rc0.d/K20shimsvc
/etc/rc1.d/K20shimsvc
/etc/rc2.d/S20shimsvc
/etc/rc3.d/S20shimsvc
/etc/rc4.d/S20shimsvc
/etc/rc5.d/S20shimsvc
/etc/rc6.d/K20shimsvc
Unpacking shim (15.7) over (15.7) …
Setting up shim (15.7) …
-su: iquery: command not found
Adding system startup for /etc/init.d/shimsvc …
/etc/rc0.d/K20shimsvc -> …/init.d/shimsvc
/etc/rc1.d/K20shimsvc -> …/init.d/shimsvc
/etc/rc6.d/K20shimsvc -> …/init.d/shimsvc
/etc/rc2.d/S20shimsvc -> …/init.d/shimsvc
/etc/rc3.d/S20shimsvc -> …/init.d/shimsvc
/etc/rc4.d/S20shimsvc -> …/init.d/shimsvc
/etc/rc5.d/S20shimsvc -> …/init.d/shimsvc
Starting shim
Processing triggers for ureadahead (0.100.0-16) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …

And then, I restarted shimsve
$> sudo /etc/init.d/shimsvc restart
Stopping shim
Starting shim

/var/lib/shim/conf file is as follows

# Shim configuration file
# Uncomment and change any of the following values. Restart shim for
# your changes to take effect (default values are shown). See
# man shim
# for more information on the options.

#ports=8080,8083s
scidbport=1239
tmp=/home/scidb/work/scidbtrunk/stage/DB-mydb/0/0/storage.cfg0
#user=root
#max_sessions=50
#timeout=60
instance=
#aio=1 

In Rstudio, I run scidbconnect()

scidbconnect()
Error in SGET("/new_session") : HTTP error 503

Then, I installed shim from source code.

$> git clone https://github.com/Paradigm4/shim.git
$> cd shim
$> make
$> ./shim

then, I tried scidbconnect() in Rstudio, then It worked.

scidbconnect()
iquery(“build(<v:double>[i=1:2,2,0, j=1:3,1,0], i*j)”, return=TRUE)
i j v
1 1 1 1
2 2 1 2
3 1 2 2
4 2 2 4
5 1 3 3
6 2 3 6

Why ? I think the binary package (~.deb) file have some problem.


#2

It may be because .deb might not be setting up the LD_LIBRARY_PATH for the shim to work properly and he git repo might already have those changes committed via various issue resolves. Had a similar problem with the shim installation. Got it fixed by fixing the path in the variable mentioned above. Setting that up has already been discussed in one of the forum posts already (if need be to look upon it further).
Hope it helps.