Shim doesn't start: cannot load libscidbclient.so libraries


#1

I’ve downloaded and installed shim using the deb package (ubuntu_14.04_shim_15.7_amd64.deb) following the guide at github.com/paradigm4/shim#non-d … stallation, but I cannot start it.

Here is the partial log from terminal when I execute the “sudo gdebi ubuntu_14.04_shim_15.7_amd64.deb” command (Shim gets correctly installed in /opt/scidb/15.7/bin/shim but it cannot start):

... Starting shim /opt/scidb/15.7/bin/shim: error while loading shared libraries: libscidbclient.so: cannot open shared object file: No such file or directory dpkg: error processing package shim (--install): subprocess installed post-installation script returned error exit status 127 Processing triggers for man-db (2.6.7.1-1ubuntu1) ... Processing triggers for ureadahead (0.100.0-16) ... Errors were encountered while processing: shim

In the Shim Notes (github.com/paradigm4/shim#notes) I’ve read: “Note: libscidbclient.so and SciDB’s boost libraries must be in shim’s library path. This may entail setting LD_LIBRARY_PATH=/opt/scidb//lib:/opt/scidb//3rdparty/boost/lib before running shim. You don’t have to worry about that if you install and run shim as a service” but I’ve noticed there is no /opt/scidb/15.7/lib folder. Could be this the problem?

I’ve tried to explicitly add “LD_LIBRARY_PATH=/opt/scidb//lib:/opt/scidb//3rdparty/boost/lib” to my ~/.bashrc file, save it, close the Terminal and check it was fine with “echo $LD_LIBRARY_PATH” but I have the same error if I try to start Shim (sudo /opt/scidb/15.7/bin/shim).

Any kind of help would be very much appreciated!


#2

No help at all?


#3

Hi,

Yeah how did you install scidb? Where is SciDB running out of? Did you build from source?
You may need to find where libscidbclient.so is and add that to LD_LIBRARY_PATH


#4

I’ve compiled SciDB from source following the “Build Instructions” at http://forum.paradigm4.com/t/release-15-7/843 step by step.
Can you please reformulate your question “Where is SciDB running out of?”

libscidbclient.so appears in:
/home/scidb/scidb/scidbtrunk/stage/install/lib/
/home/scidb/scidb/scidbtrunk/stage/build/bin/

I’ve added both to the LD_LIBRARY_PATH with no luck, I still have the error “/opt/scidb/15.7/bin/shim: error while loading shared libraries: libscidbclient.so: cannot open shared object file: No such file or directory”


#5

Hi,

A late answer, but hopefully helps others. If LD_LIBRARY_PATH does not work, you can put a symbolic link to libscidbclient.so in the same directory containing the shim binary. For example, in your case run sudo ln -s /home/scidb/scidb/scidbtrunk/stage/install/lib/libscidbclient.so /opt/scidb/15.7/bin/libscidbclient.so