Scidb.py initall fail at 31st server


#1

Hello,

I am doing an experiment using 100 servers and 2 instances per server.
The SciDB version I used is 15.7.
When I run the deployment script it failed at the 31st server when it was trying to clean up old logs and storage files.
I retried this process three times and I got the same error.
Before this I ran SciDB on 10 and 20 servers, it didn’t have any problem.

Is there an upper limit on how many servers I can use for community edition?
What would be the suggested solution for this?

Below is the error message I got:
Cleaning up old logs and storage files.
Removing data directory /home/scidb/scidbdata/n100i02/030/1 on server 30 (scidb031), local instance 1
scidb.py: ERROR: (REMOTE) Remote command exception:
exec /bin/bash -c $'source ~/.bashrc; cd /home/scidb/scidbdata/n100i02/030/1;/opt/scidb/15.7/bin/scidb --register -p 1240 -i scidb031 -s /home/scidb/scidbdata/n100i02/030/1/storage.cfg --logconf /opt/scidb/15.7/share/scidb/log4cxx.properties --install_root=/opt/scidb/15.7 -c ‘host=scidb001 port=5432 dbname=n100i02 user=n100i02’ 1> init-stdout.log 2> init-stderr.log’
Abnormal return code: 1 stderr:


#2

The log says:

2015-11-20 05:29:39,414 [0x7f21cb627800] [DEBUG]: _makeCredentials: Search for 'scidb001:5432:n100i02:n100i02:'
2015-11-20 05:31:46,689 [0x7f21cb627800] [ERROR]: System catalog connection failed: SystemException in file: src/system/catalog/SystemCatalog.cpp function: connect line: 2916
Error id: scidb::SCIDB_SE_SYSCAT::SCIDB_LE_CANT_CONNECT_PG
Error description: System catalog error. Cannot connect to PostgreSQL catalog: ‘could not connect to server: Connection timed out
Is the server running on host “scidb001” (172.31.58.169) and accepting
TCP/IP connections on port 5432?
’.

So I guess it’s PostgreSQL’s problem…
I am still looking for solutions to this…


#3

I got it solved.
Thanks.


#4

and was the solution to open more ports on the postgresql server ?


#5

Add more connection allowance on PostgreSQL server