SciDB 14.12 install problem


#1

Ubuntu 14.04

I followed the installation instructions in the pdf for the Community Edition. Following the command apt-get install scidb-14.12-installer I get the following output:


Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
account-plugin-windows-live libllvm3.6 libupstart1 linux-headers-3.16.0-30
linux-headers-3.16.0-30-generic linux-image-3.16.0-30-generic
linux-image-extra-3.16.0-30-generic llvm-3.6-runtime
Use ‘apt-get autoremove’ to remove them.
The following extra packages will be installed:
libapr1 libaprutil1 libblacs-mpi1 libblas3 libcr0 libhwloc-plugins libhwloc5
libibverbs1 liblapack3 liblog4cxx10 libopenmpi1.6 libossp-uuid16 libpqxx-3.1
libscalapack-mpi1 libscidbclient-14.12 libscidbclient-14.12-python
libtorque2 mpi-default-bin ocl-icd-libopencl1 openmpi-bin openmpi-common
postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3 python-paramiko
scidb-14.12 scidb-14.12-all-coord scidb-14.12-doc
scidb-14.12-libboost-filesystem1.54.0
scidb-14.12-libboost-program-options1.54.0 scidb-14.12-libboost-regex1.54.0
scidb-14.12-libboost-serialization1.54.0 scidb-14.12-libboost-system1.54.0
scidb-14.12-libcsv scidb-14.12-libmpich2-1.2 scidb-14.12-libmpich2-dev
scidb-14.12-mpich2 scidb-14.12-plugins scidb-14.12-utils
Suggested packages:
blcr-dkms libhwloc-contrib-plugins uuid scalapack-doc opencl-icd
openmpi-checkpoint oidentd ident-server locales-all postgresql-doc-9.3
libdbd-pg-perl
The following NEW packages will be installed:
libapr1 libaprutil1 libblacs-mpi1 libblas3 libcr0 libhwloc-plugins libhwloc5
libibverbs1 liblapack3 liblog4cxx10 libopenmpi1.6 libossp-uuid16 libpqxx-3.1
libscalapack-mpi1 libscidbclient-14.12 libscidbclient-14.12-python
libtorque2 mpi-default-bin ocl-icd-libopencl1 openmpi-bin openmpi-common
postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3 python-paramiko
scidb-14.12 scidb-14.12-all-coord scidb-14.12-doc scidb-14.12-installer
scidb-14.12-libboost-filesystem1.54.0
scidb-14.12-libboost-program-options1.54.0 scidb-14.12-libboost-regex1.54.0
scidb-14.12-libboost-serialization1.54.0 scidb-14.12-libboost-system1.54.0
scidb-14.12-libcsv scidb-14.12-libmpich2-1.2 scidb-14.12-libmpich2-dev
scidb-14.12-mpich2 scidb-14.12-plugins scidb-14.12-utils
0 upgraded, 40 newly installed, 0 to remove and 54 not upgraded.
Need to get 19.0 MB of archives.
After this operation, 82.4 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 us.archive.ubuntu.com/ubuntu/ trusty/main libapr1 amd64 1.5.0-1 [85.1 kB]
Get:2 apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main postgresql-client-9.3 amd64 9.3.9-1.pgdg14.04+1 [1,038 kB]
Get:3 us.archive.ubuntu.com/ubuntu/ trusty/main libaprutil1 amd64 1.5.3-1 [76.4 kB]
Get:4 us.archive.ubuntu.com/ubuntu/ trusty-updates/universe libhwloc5 amd64 1.8-1ubuntu1.14.04.1 [78.0 kB]
Get:5 us.archive.ubuntu.com/ubuntu/ trusty/universe ocl-icd-libopencl1 amd64 2.1.3-4 [28.1 kB]
Get:6 us.archive.ubuntu.com/ubuntu/ trusty/main libblas3 amd64 1.2.20110419-7 [215 kB]
Get:7 us.archive.ubuntu.com/ubuntu/ trusty/universe libcr0 amd64 0.8.5-2.1 [18.6 kB]
Get:8 us.archive.ubuntu.com/ubuntu/ trusty/main liblapack3 amd64 3.5.0-2ubuntu1 [1,730 kB]
Get:9 apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main postgresql-9.3 amd64 9.3.9-1.pgdg14.04+1 [3,486 kB]
Get:10 us.archive.ubuntu.com/ubuntu/ trusty/universe liblog4cxx10 amd64 0.10.0-1.2ubuntu3 [554 kB]
Get:11 us.archive.ubuntu.com/ubuntu/ trusty/main libossp-uuid16 amd64 1.6.2-1.3ubuntu1 [29.6 kB]
Get:12 us.archive.ubuntu.com/ubuntu/ trusty/universe libpqxx-3.1 amd64 1:3.1.1-0ubuntu4 [130 kB]
Get:13 us.archive.ubuntu.com/ubuntu/ trusty/universe libtorque2 amd64 2.4.16+dfsg-1.3ubuntu1 [76.3 kB]
Get:14 us.archive.ubuntu.com/ubuntu/ trusty/main libibverbs1 amd64 1.1.7-1ubuntu1 [23.3 kB]
Get:15 us.archive.ubuntu.com/ubuntu/ trusty/universe libopenmpi1.6 amd64 1.6.5-8 [1,396 kB]
Get:16 us.archive.ubuntu.com/ubuntu/ trusty/universe openmpi-common all 1.6.5-8 [101 kB]
Get:17 us.archive.ubuntu.com/ubuntu/ trusty/universe openmpi-bin amd64 1.6.5-8 [84.5 kB]
Get:18 us.archive.ubuntu.com/ubuntu/ trusty/main python-paramiko all 1.10.1-1git1build1 [106 kB]
Get:19 us.archive.ubuntu.com/ubuntu/ trusty/universe mpi-default-bin amd64 1.0.2ubuntu1 [3,252 B]
Get:20 us.archive.ubuntu.com/ubuntu/ trusty/universe libblacs-mpi1 amd64 1.1-31.1ubuntu1 [49.7 kB]
Get:21 us.archive.ubuntu.com/ubuntu/ trusty-updates/universe libhwloc-plugins amd64 1.8-1ubuntu1.14.04.1 [12.0 kB]
Get:22 us.archive.ubuntu.com/ubuntu/ trusty/universe libscalapack-mpi1 amd64 1.8.0-9build1 [2,121 kB]
Get:23 apt.postgresql.org/pub/repos/apt/ trusty-pgdg/main postgresql-contrib-9.3 amd64 9.3.9-1.pgdg14.04+1 [411 kB]
Fetched 19.0 MB in 3min 55s (80.9 kB/s)
Extracting templates from packages: 100%
Selecting previously unselected package libapr1:amd64.
(Reading database … 238850 files and directories currently installed.)
Preparing to unpack …/libapr1_1.5.0-1_amd64.deb …
Unpacking libapr1:amd64 (1.5.0-1) …
Selecting previously unselected package libaprutil1:amd64.
Preparing to unpack …/libaprutil1_1.5.3-1_amd64.deb …
Unpacking libaprutil1:amd64 (1.5.3-1) …
Selecting previously unselected package libhwloc5:amd64.
Preparing to unpack …/libhwloc5_1.8-1ubuntu1.14.04.1_amd64.deb …
Unpacking libhwloc5:amd64 (1.8-1ubuntu1.14.04.1) …
Selecting previously unselected package ocl-icd-libopencl1:amd64.
Preparing to unpack …/ocl-icd-libopencl1_2.1.3-4_amd64.deb …
Unpacking ocl-icd-libopencl1:amd64 (2.1.3-4) …
Selecting previously unselected package libblas3.
Preparing to unpack …/libblas3_1.2.20110419-7_amd64.deb …
Unpacking libblas3 (1.2.20110419-7) …
Selecting previously unselected package libcr0.
Preparing to unpack …/libcr0_0.8.5-2.1_amd64.deb …
Unpacking libcr0 (0.8.5-2.1) …
Selecting previously unselected package liblapack3.
Preparing to unpack …/liblapack3_3.5.0-2ubuntu1_amd64.deb …
Unpacking liblapack3 (3.5.0-2ubuntu1) …
Selecting previously unselected package liblog4cxx10.
Preparing to unpack …/liblog4cxx10_0.10.0-1.2ubuntu3_amd64.deb …
Unpacking liblog4cxx10 (0.10.0-1.2ubuntu3) …
Selecting previously unselected package libossp-uuid16.
Preparing to unpack …/libossp-uuid16_1.6.2-1.3ubuntu1_amd64.deb …
Unpacking libossp-uuid16 (1.6.2-1.3ubuntu1) …
Selecting previously unselected package libpqxx-3.1.
Preparing to unpack …/libpqxx-3.1_1%3a3.1.1-0ubuntu4_amd64.deb …
Unpacking libpqxx-3.1 (1:3.1.1-0ubuntu4) …
Selecting previously unselected package libtorque2.
Preparing to unpack …/libtorque2_2.4.16+dfsg-1.3ubuntu1_amd64.deb …
Unpacking libtorque2 (2.4.16+dfsg-1.3ubuntu1) …
Selecting previously unselected package libibverbs1.
Preparing to unpack …/libibverbs1_1.1.7-1ubuntu1_amd64.deb …
Unpacking libibverbs1 (1.1.7-1ubuntu1) …
Selecting previously unselected package libopenmpi1.6.
Preparing to unpack …/libopenmpi1.6_1.6.5-8_amd64.deb …
Unpacking libopenmpi1.6 (1.6.5-8) …
Selecting previously unselected package openmpi-common.
Preparing to unpack …/openmpi-common_1.6.5-8_all.deb …
Unpacking openmpi-common (1.6.5-8) …
Selecting previously unselected package openmpi-bin.
Preparing to unpack …/openmpi-bin_1.6.5-8_amd64.deb …
Unpacking openmpi-bin (1.6.5-8) …
Selecting previously unselected package postgresql-client-9.3.
Preparing to unpack …/postgresql-client-9.3_9.3.9-1.pgdg14.04+1_amd64.deb …
Unpacking postgresql-client-9.3 (9.3.9-1.pgdg14.04+1) …
Selecting previously unselected package postgresql-9.3.
Preparing to unpack …/postgresql-9.3_9.3.9-1.pgdg14.04+1_amd64.deb …
Unpacking postgresql-9.3 (9.3.9-1.pgdg14.04+1) …
Selecting previously unselected package postgresql-contrib-9.3.
Preparing to unpack …/postgresql-contrib-9.3_9.3.9-1.pgdg14.04+1_amd64.deb …
Unpacking postgresql-contrib-9.3 (9.3.9-1.pgdg14.04+1) …
Selecting previously unselected package python-paramiko.
Preparing to unpack …/python-paramiko_1.10.1-1git1build1_all.deb …
Unpacking python-paramiko (1.10.1-1git1build1) …
Selecting previously unselected package scidb-14.12-libboost-system1.54.0.
Preparing to unpack …/scidb-14.12-libboost-system1.54.0_1.54.0-2.1_amd64.deb …
Unpacking scidb-14.12-libboost-system1.54.0 (1.54.0-2.1) …
Selecting previously unselected package scidb-14.12-libboost-filesystem1.54.0.
Preparing to unpack …/scidb-14.12-libboost-filesystem1.54.0_1.54.0-2.1_amd64.deb …
Unpacking scidb-14.12-libboost-filesystem1.54.0 (1.54.0-2.1) …
Selecting previously unselected package scidb-14.12-libboost-program-options1.54.0.
Preparing to unpack …/scidb-14.12-libboost-program-options1.54.0_1.54.0-2.1_amd64.deb …
Unpacking scidb-14.12-libboost-program-options1.54.0 (1.54.0-2.1) …
Selecting previously unselected package scidb-14.12-libboost-regex1.54.0.
Preparing to unpack …/scidb-14.12-libboost-regex1.54.0_1.54.0-2.1_amd64.deb …
Unpacking scidb-14.12-libboost-regex1.54.0 (1.54.0-2.1) …
Selecting previously unselected package scidb-14.12-libboost-serialization1.54.0.
Preparing to unpack …/scidb-14.12-libboost-serialization1.54.0_1.54.0-2.1_amd64.deb …
Unpacking scidb-14.12-libboost-serialization1.54.0 (1.54.0-2.1) …
Selecting previously unselected package mpi-default-bin.
Preparing to unpack …/mpi-default-bin_1.0.2ubuntu1_amd64.deb …
Unpacking mpi-default-bin (1.0.2ubuntu1) …
Selecting previously unselected package libblacs-mpi1.
Preparing to unpack …/libblacs-mpi1_1.1-31.1ubuntu1_amd64.deb …
Unpacking libblacs-mpi1 (1.1-31.1ubuntu1) …
Selecting previously unselected package libhwloc-plugins.
Preparing to unpack …/libhwloc-plugins_1.8-1ubuntu1.14.04.1_amd64.deb …
Unpacking libhwloc-plugins (1.8-1ubuntu1.14.04.1) …
Selecting previously unselected package libscalapack-mpi1.
Preparing to unpack …/libscalapack-mpi1_1.8.0-9build1_amd64.deb …
Unpacking libscalapack-mpi1 (1.8.0-9build1) …
Selecting previously unselected package libscidbclient-14.12.
Preparing to unpack …/libscidbclient-14.12_0-9095_amd64.deb …
Unpacking libscidbclient-14.12 (0-9095) …
Selecting previously unselected package libscidbclient-14.12-python.
Preparing to unpack …/libscidbclient-14.12-python_0-9095_amd64.deb …
Unpacking libscidbclient-14.12-python (0-9095) …
Selecting previously unselected package scidb-14.12-libcsv.
Preparing to unpack …/scidb-14.12-libcsv_3.0.3-1_amd64.deb …
Unpacking scidb-14.12-libcsv (3.0.3-1) …
Selecting previously unselected package scidb-14.12.
Preparing to unpack …/scidb-14.12_0-9095_amd64.deb …
Unpacking scidb-14.12 (0-9095) …
Selecting previously unselected package scidb-14.12-utils.
Preparing to unpack …/scidb-14.12-utils_0-9095_amd64.deb …
Unpacking scidb-14.12-utils (0-9095) …
Selecting previously unselected package scidb-14.12-libmpich2-1.2.
Preparing to unpack …/scidb-14.12-libmpich2-1.2_1.2.1.1-4_amd64.deb …
Unpacking scidb-14.12-libmpich2-1.2 (1.2.1.1-4) …
Selecting previously unselected package scidb-14.12-mpich2.
Preparing to unpack …/scidb-14.12-mpich2_1.2.1.1-4_amd64.deb …
Unpacking scidb-14.12-mpich2 (1.2.1.1-4) …
Selecting previously unselected package scidb-14.12-plugins.
Preparing to unpack …/scidb-14.12-plugins_0-9095_amd64.deb …
Unpacking scidb-14.12-plugins (0-9095) …
Selecting previously unselected package scidb-14.12-doc.
Preparing to unpack …/scidb-14.12-doc_0-9095_all.deb …
Unpacking scidb-14.12-doc (0-9095) …
Selecting previously unselected package scidb-14.12-all-coord.
Preparing to unpack …/scidb-14.12-all-coord_0-9095_amd64.deb …
Unpacking scidb-14.12-all-coord (0-9095) …
Selecting previously unselected package scidb-14.12-installer.
Preparing to unpack …/scidb-14.12-installer_0_all.deb …
Unpacking scidb-14.12-installer (0) …
Selecting previously unselected package scidb-14.12-libmpich2-dev.
Preparing to unpack …/scidb-14.12-libmpich2-dev_1.2.1.1-4_amd64.deb …
Unpacking scidb-14.12-libmpich2-dev (1.2.1.1-4) …
Processing triggers for man-db (2.6.7.1-1ubuntu1) …
Processing triggers for doc-base (0.10.5) …
Processing 1 added doc-base file…
Registering documents with scrollkeeper…
Processing triggers for postgresql-common (169.pgdg14.04+1) …
Building PostgreSQL dictionaries from installed myspell/hunspell packages…
en_au
en_gb
en_us
en_za
Removing obsolete dictionary files:
Setting up libapr1:amd64 (1.5.0-1) …
Setting up libaprutil1:amd64 (1.5.3-1) …
Setting up libhwloc5:amd64 (1.8-1ubuntu1.14.04.1) …
Setting up ocl-icd-libopencl1:amd64 (2.1.3-4) …
Setting up libblas3 (1.2.20110419-7) …
update-alternatives: using /usr/lib/libblas/libblas.so.3 to provide /usr/lib/libblas.so.3 (libblas.so.3) in auto mode
Setting up libcr0 (0.8.5-2.1) …
Setting up liblapack3 (3.5.0-2ubuntu1) …
update-alternatives: using /usr/lib/lapack/liblapack.so.3 to provide /usr/lib/liblapack.so.3 (liblapack.so.3) in auto mode
Setting up liblog4cxx10 (0.10.0-1.2ubuntu3) …
Setting up libossp-uuid16 (1.6.2-1.3ubuntu1) …
Setting up libpqxx-3.1 (1:3.1.1-0ubuntu4) …
Setting up libtorque2 (2.4.16+dfsg-1.3ubuntu1) …
Setting up libibverbs1 (1.1.7-1ubuntu1) …
Setting up libopenmpi1.6 (1.6.5-8) …
Setting up openmpi-common (1.6.5-8) …
Setting up openmpi-bin (1.6.5-8) …
update-alternatives: using /usr/bin/mpirun.openmpi to provide /usr/bin/mpirun (mpirun) in auto mode
Setting up postgresql-client-9.3 (9.3.9-1.pgdg14.04+1) …
Setting up postgresql-9.3 (9.3.9-1.pgdg14.04+1) …
Creating new cluster 9.3/main …
config /etc/postgresql/9.3/main
data /var/lib/postgresql/9.3/main
locale en_US.UTF-8
Flags of /var/lib/postgresql/9.3/main set as -------------e-C
port 5433

  • Starting PostgreSQL 9.3 database server [ OK ]
    Setting up postgresql-contrib-9.3 (9.3.9-1.pgdg14.04+1) …
    Setting up python-paramiko (1.10.1-1git1build1) …
    Setting up scidb-14.12-libboost-system1.54.0 (1.54.0-2.1) …
    Setting up scidb-14.12-libboost-filesystem1.54.0 (1.54.0-2.1) …
    Setting up scidb-14.12-libboost-program-options1.54.0 (1.54.0-2.1) …
    Setting up scidb-14.12-libboost-regex1.54.0 (1.54.0-2.1) …
    Setting up scidb-14.12-libboost-serialization1.54.0 (1.54.0-2.1) …
    Setting up mpi-default-bin (1.0.2ubuntu1) …
    Setting up libblacs-mpi1 (1.1-31.1ubuntu1) …
    Setting up libhwloc-plugins (1.8-1ubuntu1.14.04.1) …
    Setting up libscalapack-mpi1 (1.8.0-9build1) …
    Setting up libscidbclient-14.12 (0-9095) …
    Setting up libscidbclient-14.12-python (0-9095) …
    Setting up scidb-14.12-libcsv (3.0.3-1) …
    Setting up scidb-14.12 (0-9095) …
    Setting up scidb-14.12-utils (0-9095) …
    Setting up scidb-14.12-libmpich2-1.2 (1.2.1.1-4) …
    Setting up scidb-14.12-mpich2 (1.2.1.1-4) …
    update-alternatives: renaming mpirun link from /usr/bin/mpirun to /opt/scidb/14.12/3rdparty/mpich2/bin/mpirun
    update-alternatives: renaming mpiexec slave link from /usr/bin/mpiexec to /opt/scidb/14.12/3rdparty/mpich2/bin/mpiexec
    Setting up scidb-14.12-plugins (0-9095) …
    update-alternatives: using /opt/scidb/14.12/lib/scidb/plugins/libdense_linear_algebra-scidb.so to provide /opt/scidb/14.12/lib/scidb/plugins/libdense_linear_algebra.so (dense_linear_algebra.14.12) in auto mode
    update-alternatives: using /opt/scidb/14.12/lib/scidb/plugins/liblinear_algebra-scidb.so to provide /opt/scidb/14.12/lib/scidb/plugins/liblinear_algebra.so (linear_algebra.14.12) in auto mode
    Setting up scidb-14.12-doc (0-9095) …
    Setting up scidb-14.12-all-coord (0-9095) …
    Setting up scidb-14.12-installer (0) …
    Generating public/private rsa key pair.
    Created directory ‘/home/scidb/.ssh’.
    Your identification has been saved in /home/scidb/.ssh/id_rsa.
    Your public key has been saved in /home/scidb/.ssh/id_rsa.pub.
    The key fingerprint is:
    b1:c7:75:95:04:4e:89:3b:55:b0:e8:27:62:cc:03:af scidb@travis-Inspiron-5720
    The key’s randomart image is:
    ±-[ RSA 2048]----+
    | .+*oo|
    | .+o.o |
    | … .+o. |
    | =+.+ . |
    | SBoo… |
    | o.o o |
    | E |
    | |
    | |
    ±----------------+
    /opt/scidb/14.12/script/setup_postgresql.sh: line 35: [: /etc/postgresql/9.3/main/pg_hba.conf: binary operator expected
    sed: couldn’t edit /dev/null: not a regular file
    sed: couldn’t edit /dev/null: not a regular file
    /opt/scidb/14.12/script/setup_postgresql.sh: line 62: [: /etc/postgresql/9.3/main/pg_hba.conf: binary operator expected
    is the result
    Adding user scidb_pg_user…
    CREATE ROLE
    UPDATE 1
    GRANT
    Sample of connection string:
    host=localhost port=5432 dbname=single_server user=scidb_pg_user password=scidb_pg_user_pasw
    Executing java.sh
    Using XRD at /usr/local/xrootd/xrootd_git
    /usr/local/xrootd/xrootd_git
    /etc/profile.d
    /etc
    /usr/local/root/root-6.04.00-debug
    /opt/scidb/14.12/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 [Errno 111] Connection refused
    Executing java.sh
    Using XRD at /usr/local/xrootd/xrootd_git
    /usr/local/xrootd/xrootd_git
    /etc/profile.d
    /etc
    /usr/local/root/root-6.04.00-debug
    /opt/scidb/14.12/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 [Errno 111] Connection refused
    Setting up scidb-14.12-libmpich2-dev (1.2.1.1-4) …
    update-alternatives: using /opt/scidb/14.12/3rdparty/mpich2/include/mpich2 to provide /opt/scidb/14.12/3rdparty/mpich2/include/mpi (mpi) in auto mode
    Processing triggers for libc-bin (2.19-0ubuntu6.6) …

I logged in as scidb user and typed "source /home/scidb/.bashrc"
I then typed iquery and got the following message:

4 [0x7fef355687c0] FATAL scidb.services.network null - Error #system:111 when connecting to localhost:1239
4 [0x7fef355687c0] FATAL scidb.services.network null - Error #system:111 when connecting to localhost:1239
iquery SystemException in file: src/network/BaseConnection.cpp function: connect line: 262
Error id: scidb::SCIDB_SE_NETWORK::SCIDB_LE_CONNECTION_ERROR
Error description: Network error. Error #system:111 when connecting to localhost:1239.

I searched the forums for a possible solution and someone suggested checking whether a scidb instance had been started. So I typed in ps -eaf | grep -i scidb
travis 4337 15375 0 10:33 ? 00:00:02 evince /home/travis/Downloads/SciDB_Build_Instructions_14.12.pdf
root 4633 4394 0 10:47 pts/25 00:00:00 su scidb
scidb 4635 4633 0 10:47 pts/25 00:00:00 bash
scidb 5143 4635 0 11:17 pts/25 00:00:00 ps -eaf
scidb 5144 4635 0 11:17 pts/25 00:00:00 grep --color=auto -i scidb
travis 25299 15375 0 Jun22 ? 00:00:21 evince /home/travis/Downloads/SciDB-Installation-v14.12.pdf

Anyone have some ideas about how to proceed next?

Thanks.


#2

/opt/scidb/14.12/script/setup_postgresql.sh: line 35: [: /etc/postgresql/9.3/main/pg_hba.conf: binary operator expected

It gets to this line because the script can not find the pg_hba.conf file for postgres.
For Ubuntu it is looking for /etc/postgresql/9.3/main/pg_hba.conf

Can you check your postgres installation ?
Thanks


#3

/opt/scidb/14.12/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 [Errno 111] Connection refused

Also - is ssh running on localhost ?
and if so what port is it on ?


#4

Thanks for the fast reply. Your diagnosis about ssh was correct. The problem was that I didn’t have an ssh server. After installing SSH server and enabling empty passwords, I was able to reinstall scidb and get it working. Maybe the configuration scripts should check for ssh in the future and download the ssh package if it isn’t there?

A quick question: are empty passwords necessary for ssh? After doing the above steps, I went back to the ssh config and turned off empty passwords. iquery seemed to work just fine.


#5

My understanding is that passwordless ssh is used to start and stop SciDB. Iquery uses port 1239.


#6

I also had a problem with installation:

$ sudo apt-get install scidb-14.12-installer
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
scidb-14.12-installer : Depends: scidb-14.12-all-coord but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then:

sudo apt-get install scidb-14.12-all-coord
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
scidb-14.12-all-coord : Depends: scidb-14.12 (= 0-9095) but it is not going to be installed
Depends: libscidbclient-14.12 (= 0-9095) but it is not going to be installed
Depends: scidb-14.12-utils (= 0-9095) but it is not going to be installed
Depends: scidb-14.12-plugins (= 0-9095) but it is not going to be installed
Depends: libscidbclient-14.12-python (= 0-9095) but it is not going to be installed
Depends: postgresql-client-8.4 but it is not installable
Depends: postgresql-8.4 but it is not installable
Depends: postgresql-contrib-8.4 but it is not installable
E: Unable to correct problems, you have held broken packages.

At the end it requires libicu48 but ubuntu 14.04 supports only libicu52 :exclamation:


#7

make sure you are getting the SciDB 14.12 for Ubuntu 14.04, not the one for 12.04

i.e. check the /etc/apt/sources.list.d/scidb.list
deb downloads.paradigm4.com/ ubuntu14.04/14.12/
deb-src downloads.paradigm4.com/ ubuntu14.04/14.12/

not the one from the installation note:
deb downloads.paradigm4.com/ ubuntu12.04/14.12/
deb-src downloads.paradigm4.com/ ubuntu12.04/14.12/


#8

Patrick is correct, it looks like you have a u1204 installation.

For Ubuntu 1404 the postgresql is 9.3
For Ubuntu 1204 the postgresql is 8.4

Your output indicates postgresql at 8.4 yet you are asking about 14.04