Registering SciDB; need sudo privileges to config postgres


#1

I’m a novice ubuntu/scidb user, and I’m at the Initialization/Startup setup stage for SciDB. Here is the message I get when I try to initialize:

scidb@anthony-MacBookPro:/opt/scidb/12.3/bin$ scidb.py initall SingleInstance
Cleaning up old logs and storage files.
Move/unlink directory (server 0 (localhost) local instance 0 /home/scidb/DB-SingleInstance/000/0 -> /home/scidb/DB-SingleInstance/000/0-20120607-142533)
init(server 0 (localhost) local instance 0)
Reinitializing and registering local scidb instance/storage.

sudo privileges are required to configure the postgres database.
scidb@anthony-MacBookPro:/opt/scidb/12.3/bin$ C

I thought I had given sudo privileges, but I imagine something went wrong. This has become a rather annoying hitch in this process for me, so any help would be GREATLY appreciated.

Best,
Anthony


#2

Hi Anthony,

Unfortunately it stupidly spits out that message all the time - but that message alone should not be indicative of an error case. It’s just a case of an unfriendly message. You should be able to start scidb and load data. Have you tried it?

  • Alex Poliakov

#3

Thanks so much! It appears to be working fine now that i’ve actually tried it.

~Anthony