Problems installing scidb-12.10.0.5777-Cheshire-final


#1

I downloaded scidb-12.10.0.5777-Cheshire-final.tar.gz and followed the instructions for my CentOS 6.3, installing the packages from repositories and from sources as instructed.

The cmake . fails with message:

[code]CMake Error at tests/harness/CMakeLists.txt:26 (if):
if given arguments:

"LESS" "2" "AND" "LESS" "46"

Unknown arguments specified

– Configuring incomplete, errors occurred!
[/code]
after several complaining (warnings) mostly about unexisting BLAS, LAPACK, MPI, SCALAPACK.

I have installed[root@server /root/software] rpm -qa blas lapack boost boost-devel blas-3.2.1-4.el6.x86_64 boost-devel-1.41.0-11.el6_1.2.x86_64 lapack-3.2.1-4.el6.x86_64 boost-1.41.0-11.el6_1.2.x86_64
No SCALAPACK, but it is not defined as a requirement.

Since the error message apparently is about Boost, I also tried to install it from source, following the instructions in build.txt for other systems, with no success (and probably messing up something…).

Can someone please help me?

Thank you,
Giorgio


#2

Giorgio,

We’ve seen the “LESS” “2” problem many times. It happens when you have a version of boost pre-installed that is too old. Then the CMake script goes to find the boost version, starts talking to the old version by accident and gets confused.

You need to remove the existing boost version and install it from souce. Take another look at build.txt - there should be a “wget” statement for how to build boost. You should use that.


#3

Thank you very much for the answer.
I uninstalled all the boost-related packages from my CentOS 6.3, and installed the Boost library from sources following the instructions in ‘build.txt’.
Eventually I ended with still the same problem with CMake.

CMake Error at tests/harness/CMakeLists.txt:26 (if): if given arguments: "LESS" "2" "AND" "LESS" "46" Unknown arguments specified -- Configuring incomplete, errors occurred!
The instruction in build.txt refer to a Boost 1.42. Should I try with the current release, 1.52, from the site boost.org?

Giorgio


#4

Giorgio -

Try boost 1.46. This is what’s installed on my dev machine.


$ cat /usr/include/boost/version.hpp 
//  Boost version.hpp configuration header file  ------------------------------//

//  (C) Copyright John maddock 1999. Distributed under the Boost
//  Software License, Version 1.0. (See accompanying file
//  LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)

//  See http://www.boost.org/libs/config for documentation

#ifndef BOOST_VERSION_HPP
#define BOOST_VERSION_HPP

//
//  Caution, this is the only boost header that is guarenteed
//  to change with every boost release, including this header
//  will cause a recompile every time a new boost version is
//  released.
//
//  BOOST_VERSION % 100 is the patch level
//  BOOST_VERSION / 100 % 1000 is the minor version
//  BOOST_VERSION / 100000 is the major version

#define BOOST_VERSION 104601

//
//  BOOST_LIB_VERSION must be defined to be the same as BOOST_VERSION
//  but as a *string* in the form "x_y[_z]" where x is the major version
//  number, y is the minor version number, and z is the patch level if not 0.
//  This is used by <config/auto_link.hpp> to select which library version to link to.

#define BOOST_LIB_VERSION "1_46_1"

#5

I encountered the same error when trying to build SciDB 12.10 on CentOS 6.2. Tried building different version of Boost including 1.42 and 1.46.1 but still didn’t work.

From the errors I wonder do we need to define Boost_MAJOR_VERSION and Boost_MINOR_VERSION in the shell/script first?


#6

Thank you plumber,
I did as you suggested, no luck.

I understood that uninstalling a Boost version is removing /usr/local/include/boost and /usr/local/lib/libboost_* (at least those are all the file with dates compatible I can find with ‘find /usr’), since there is no ‘make unistall’ int the Boost distribution. So I unistalled what I made and installed (with the same parameters for ‘bjam’) the 1.46 (taken from boost.org).

Running ‘cmake .’ in the SciDB directory gives me the same result.

Browsing the Boost site I found (in boost.org/users/history/) that

[quote]Version 1.41.0
November 17th, 2009 17:00 GMT
[…] The CMake build system for Boost, still under development here, has been removed from the main release to avoid confusion.
[/quote]
Actually, I don’t find any ‘*.cmake’ file in the Boost tree, if any is needed. I’m totally unfamiliar with either CMake or Boost, so I’m clueless.

By the way the ‘here’ mentioned in the Boost site (sodium.resophonic.com/boost-cmake/current-docs/) is an unreachable site.

As a final note, I found the probable work continuation site for Boost-CMake, github.com/pocb/boost, I tried to install the Boost 1.46 starting from their Git repository, with the usual process as in the SciDB build.txt, but the result is the same for the ‘cmake .’ of SciDB.

Thank you for the support,
Giorgio