Problem with running command scidb.py startall cluster


#1

I have installed SciDB in my system as per the instructions in scidb-installation-video. After successfully installed SciDB in ubuntu 12.04, I tried to execute the command scidb.py startall cluster, I amgetting the following error message.

/opt/scidb/14.8/bin/scidb.py: ERROR: ssh failure: server=subu-desktop port=22 No authentication methods available

I am expecting a valuable solution for rectifying this error.


#2

If you used cluster install script, then you specified username for use by scidb. Please run the following command and post its output:

ssh @subu-desktop -v


#3

the output obtained is as follows

subu@subu-desktop:~$ ssh scidb@subu-desktop-v
ssh: Could not resolve hostname subu-desktop-v: Name or service not known


#4

-v is the switch to ssh: make sure to include a space between the name of the machine and -v switch. Please run the command as follows:


#5

subu@subu-desktop:~$ ssh scidb@subu-desktop -v
OpenSSH_5.9p1 Debian-5ubuntu1.4, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to subu-desktop [127.0.1.1] port 22.
debug1: Connection established.
debug1: SELinux support disabled
debug1: identity file /home/subu/.ssh/id_rsa type -1
debug1: identity file /home/subu/.ssh/id_rsa-cert type -1
debug1: identity file /home/subu/.ssh/id_dsa type -1
debug1: identity file /home/subu/.ssh/id_dsa-cert type -1
debug1: identity file /home/subu/.ssh/id_ecdsa type -1
debug1: identity file /home/subu/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.9p1 Debian-5ubuntu1.4
debug1: match: OpenSSH_5.9p1 Debian-5ubuntu1.4 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1.4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA 53:73:e4:19:3c:d0:14:45:18:9e:6b:10:64:88:be:9d
The authenticity of host ‘subu-desktop (127.0.1.1)’ can’t be established.
ECDSA key fingerprint is 53:73:e4:19:3c:d0:14:45:18:9e:6b:10:64:88:be:9d.
Are you sure you want to continue connecting (yes/no)? y
Please type ‘yes’ or ‘no’: yes
Warning: Permanently added ‘subu-desktop’ (ECDSA) to the list of known hosts.
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/subu/.ssh/id_rsa
debug1: Trying private key: /home/subu/.ssh/id_dsa
debug1: Trying private key: /home/subu/.ssh/id_ecdsa
debug1: Next authentication method: password
scidb@subu-desktop’s password:
debug1: Authentication succeeded (password).
Authenticated to subu-desktop ([127.0.1.1]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_IN
Welcome to Ubuntu 12.04.5 LTS (GNU/Linux 3.8.0-44-generic x86_64)

New release ‘14.04.1 LTS’ available.
Run ‘do-release-upgrade’ to upgrade to it.

Your current Hardware Enablement Stack (HWE) is no longer supported
since 2014-08-07. Security updates for critical parts (kernel
and graphics stack) of your system are no longer available.

For more information, please see:
wiki.ubuntu.com/1204_HWE_EOL

There is a graphics stack installed on this system. An upgrade to a
supported (or longer supported) configuration will become available
on 2014-07-16 and can be invoked by running ‘update-manager’ in the
Dash.


#6

Does the login succeed or does it fail?


#7

Succeeded


#8

Another idea is to set your shell to /bin/bash instead of dash (which is the default on Ubuntu).


#9

If scidb is not running, please try to re-run the initall command:

If the command fails, please post the output. If the command succeeds, please try re-running the startall command.


#10

As you have suggested i verified the shell. It was bash.
Latter on I tried to run scidb. The output generated is as follows.
scidb@subu-desktop:~$ echo $SHELL
/bin/bash
scidb@subu-desktop:~$ scidb.py startall cluster
Found 0 scidb processes
start(server 0 (subu-desktop) local instance 0)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 1)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 2)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 3)
Starting SciDB server.
/opt/scidb/14.8/bin/scidb.py: ERROR: Failed to start SciDB!


#11

Alright. Something seems to be still not right in terms of networking. Please post the contents of /etc/hosts file.

At the same time, you can try putting the actual IP of your machine into the config.ini file instead of the DNS name of the machine (subu-desktop). Re-run the initall command and try restarting scidb.


#12

As you suggested i executed the scidb.py -v initall cluster command and the output given below.

[color=#0000BF]scidb@subu-desktop:~$ scidb.py -v initall cluster
/opt/scidb/14.8/bin/scidb.py: DEBUG: Remote command=exec /bin/bash -c $'ps --no-headers -e -o pid,cmd | awk ‘{print $1 " " $2}’ | grep “/home/scidb/scidb_data/000/*” | awk ‘{print $1}’'
Found 0 scidb processes
/opt/scidb/14.8/bin/scidb.py: DEBUG: Remote command=exec /bin/bash -c $‘export PGPASSWORD=pguserpwd;psql -h subu-desktop -p 5432 --username pguser --dbname cluster -t -c “SELECT * FROM pg_settings WHERE name = ‘max_connections’;”’[/color]

After that tried to run scidb and the output generated as follows.

[color=#0000FF]scidb@subu-desktop:~$ scidb.py startall cluster
Found 0 scidb processes
start(server 0 (subu-desktop) local instance 0)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 1)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 2)
Starting SciDB server.
start(server 0 (subu-desktop) local instance 3)
Starting SciDB server.
/opt/scidb/14.8/bin/scidb.py: ERROR: Failed to start SciDB!
scidb@subu-desktop:~$
[/color]


#13

Was that the full output from the initall command? If so, it may be that postgres is not running. Please run the following command and post the output:

Also, if you could post your config.ini that would be good.


#14

scidb@subu-desktop:~$ service postgresql status
Running clusters: 8.4/main
Running clusters: 9.1/main


#15

Alright - it seems that you have 2 different versions of postgres running simultaneously. What we need to do now is find out what ports they are listening on. Please follow these steps
[ul]
[li]run the command ps -ef | grep postg[/li]
[li]find the lines which correspond to the postgres service (postgres config file will be pasrt of the command line)[/li]
[li]take a look in the config files for postgres for a line matching the pattern “port=”[/li][/ul]

In your case you should have 2 distinct postgres services: so you may need to look in 2 files. It seems that 2 different postgres installations are interfering with each other. Please post the port(s) postgres services are listening on.


#16

Following are port numbers found in their corresponding config files
postgress8.4 -------------------> port=5433

postgress9.1--------------------> port=5432


#17

Both postgres services seem to be running at the same time and on different ports. 14.8 was built to use postgres 8.4. You can try the following:

[ul]
[li] Specify an extra setting in your config.ini file (pg-port=5433)[/li]
[li] Re-run init_syscat command (scidb.py init_syscat )[/li]
[li] Re-run initall command (scidb.py initall )[/li]
[li] Try restarting scidb (scidb.py startall )[/li][/ul]

Let us know how you get on. If there are any errors during the execution of the above steps, post them of course.


#18

As you are suggested, I have added a new line [color=#0000BF]pg-port=5433[/color] in the [color=#FF0000]config.ini[/color] file

Then i tried to run the command [color=#0000BF]scidb.py init_syscat cluster[/color], i got the following error.

[color=#0000BF]scidb@subu-desktop:~$ scidb.py init_syscat cluster
You must run this script as owner of PostgreSQL!
/opt/scidb/14.8/bin/scidb.py: ERROR: Abnormal return code: 1
/opt/scidb/14.8/bin/scidb.py: ERROR: command /opt/scidb/14.8/bin/init-db.sh pguser cluster pguserpwd 5433: [/color]


#19

Just to be clear - “cluster” is the name of your cluster from config.ini? You have not posted the contents of your config.ini - so I have to ask.
Please try running that command as follows:


#20

my config.ini file content is as follows
[color=#0000BF][cluster]
server-0=subu-desktop,3
install_root=/opt/scidb/14.8
metadata=/opt/scidb/14.8/share/scidb/meta.sql
pluginsdir=/opt/scidb/14.8/lib/scidb/plugins
logconf=/opt/scidb/14.8/share/scidb/log4cxx.properties
db_user=pguser
db_passwd=pguserpwd
base-port=1239
base-path=/home/scidb/scidb_data
redundancy=0
execution-threads=1
result-prefetch-threads=1
result-prefetch-queue-size=1
operator-threads=1
pg-port=5433[/color]

As you suggested i executed the command given in the last post and obtained following output
[color=#0000BF]scidb@subu-desktop:~$ sudo -u scidb.py init_syscat cluster
sudo: unknown user: scidb.py
sudo: unable to initialize policy plugin[/color]