Problem with memory while stacking array


#1

Hello!

I faced next problem: while trying to create ‘doubled’ (in terms of one of the dimensions) array, SciDB keeps showing different error messages - either “no memory” or “connection” error.

This is schema of the initial array: value:uint16[time=0:8,1,0,lat=0:7940,256,0,lon=0:7970,256,0];
The data is satellite image, so it’s pretty dense. And after filling it with values from file, I try to expand it along with time dimension to this schema: value:uint16[time=0:*,1,0,lat=0:7940,256,0,lon=0:7970,256,0];

The way I try to ‘double it’ is: tore(xgrid(src_arr,2,1,1),doub_arr);

And 2 errors I keep receiving:
SystemException in file: src/network/BaseConnection.h function: receive line: 426
Error id: scidb::SCIDB_SE_NETWORK::SCIDB_LE_CANT_SEND_RECEIVE
Error description: Network error. Cannot receive network message: Read failed: End of file (asio.misc:2). An instance may be offline…

SystemException in file: src/util/arena/Arena.cpp function: exhausted line: 504
Error id: scidb::SCIDB_SE_NO_MEMORY::SCIDB_LE_ARENA_EXHAUSTED
Error description: Not enough memory. An attempt was made to allocate more memory than is available.
arena : {name=“root”,available=unlimited,allocated=1.7GiB,peakusage=1.7GiB,allocations=225315,features=“FCT”}
request: 64MiB.
Failed query id: 0.1493319415515335129

My question is what am I doing wrong? The chunking is 1x256x256, so it doesn’t make sense why so much memory is allocated at a time…
I also tried other ways to grow this array, which were listed in different topics of this forum, but none of it worked for me.

In case any additional data is needed (e.g. config.ini or scidb.log) - let me know, I’ll share it!

Thanks!