Problem while building SciDB 16.9


#1

Hello,

I’m trying to build SciDB on a VM with ubuntu 14.04. I completed the pre-installation tasks and ran “./run.py setup” successfully, but when running “./run.py make -j4”

the following error occurs:

[ 7%] Building CXX object examples/complex/CMakeFiles/complex.dir/complex.cpp.o
g+±4.9: internal compiler error: Killed (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
make[2]: *** [src/linear_algebra/CMakeFiles/linear_algebra.dir/spgemm/PhysicalSpgemm.cpp.o] Error 4
make[1]: *** [src/linear_algebra/CMakeFiles/linear_algebra.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…

The script then moves on with some other commands and finally terminates with the following message:

setup.py exited with 0
[ 7%] No install step for ‘scalapackForMPICH2’
[ 7%] Completed ‘scalapackForMPICH2’
[ 7%] Built target scalapackForMPICH2
make: *** [all] Error 2
run.py: ERROR: Command make failed: Abnormal return code: 2 on command [’/usr/bin/make’, ‘-j4’]
run.py: ERROR: Make sure commands setup,make,install,start are performed (in that order) before stop,stopForce,tests

Anybody knows what might be the problem here?

Thank you in advance,
Nantia


#2

Good morning,
I’m sorry to see that you’re having trouble building SciDB 16.9 from source on Ubuntu 14.04. Are you building the community or enterprise edition? Also, can you please send along, perhaps in a forum message, the output of the following commands?
uname -a cat /proc/meminfo cat /proc/cpuinfo cat /etc/issue
Thanks!
Dave


#3

Hello Dave,

thank you for your reply!

It’s the community edition. I sent you the output of the commands in a forum message.


#4

Hi @nantiamakr,
Thank you for sending-along that output. What I think is going on is that you are running out of memory and Linux is killing the compiler. It looks like you’re running a single CPU and 3GB of RAM. ./run.py make -j4 will start four compiler instances simultaneously which is great if there are four CPUs available. Correspondingly, they’ll consume 4x the RAM of one instance, too. I suggest trying the following–it’ll take longer to compile, but it should complete: ./run.py make -j1. The output of your cat /proc/meminfo shows that your system doesn’t have swap enabled. Enabling swap will allow your system to fall back to disk should it fill RAM; consider enabling swap if you see “internal compiler error” again.
Thanks!
Dave


#5

@dgosselin Thank you for the suggestions.

I can try installing SciDB in another machine with better specs, but I would like to avoid enabling the root user there. Is that possible? As far as I understand from the instructions, it is not. However, there are older posts that mention that you intended to change that by now or that one can use sudo instead.


#6

You may be successful installing the product on the machine that you have presently by changing the -j4 argument to -j1, did that work for you?


#7

I finally managed to install SciDB on the current machine by using -j1 and closing any other program apart from the terminal. :slight_smile:

Thanks a lot for your help!


#8

@nantiamakr, glad to hear it! :smile: