Problem install: ssh localhost did not work


#1

Dear fellow SciDB users,

I am new to Linux and I am trying to install SciDB. However I cant seem to fix the following error during installation, maybe related to this post:

[code]root using password-less ssh key ‘id_rsa’.
Hardcoding this key for use with the hosts specified in the configuration file
into your .ssh/config file.

Confirming ‘ssh localhost hostname’ works…

ssh to localhost did not work.

There was a problem ssh’ing from this host (¨mysystemname¨) to this host (localhost) as root

The ssh port 22 is available.
The ‘ssh’ daemon is running.

I have no idea what the problem is.
[/code]

I have spent the whole day without succeed :frowning: Tried to change the sshd_config, config.ini, restarting my laptop and reinstalling the ssh, none worked. Appreciate very very much if anyone can help. Many thanks!

Hadi


#2

To be honest … from where I am? Your problem isn’t SciDB related.

Your problem seems to be that the sshd (http://en.wikipedia.org/wiki/Secure_Shell) isn’t installed or isn’t working.


#3

Hi Plumber,

Haha do you mean where myself is from? I am an MSc student at ITC, University of Twente, the Netherlands. I recently discovered SciDB that I can use for my analysis in my ongoing thesis, which is evaluating all 3-band spectral indices from hyperspectral data (584 bands x 584 bands x 584 bands combinations x 185 samples, R memory and even bigmemory package can’t handle, while ff is unusable as well cause R can only store array element index up to 2^32 i.e. 32 bits) in terms of predicting my response variable. Therefore, I am thinking to store the huge array of spectral indices values in SciDB and iterate for every cell (apply linear regression) with iquery from within R, and store the R2 and RMSE array in SciDb as well.

Back to the problem, so it’s not about the cluster_install and config.ini, but solely the sshd yeah? I am wondering is it because I am installing to my standalone laptop (do I need ssh?)? At the moment I will not work with remote server/user, can I sort of ‘remove’ the ssh configuration step during the installation? Just to make sure, SciDB does support Ubuntu 14.04.02, correct? Thanks so much. I really hope I can get this to work because optimizing 3-band spectral indices is quite new in the field of hyperspectral remote sensing.

Hadi


#4

i run into this too
there is a setting in sshd_config (/etc/ssh/sshd_config

called
PermitUserLogin Yes

make sure to uncomment that. This works in ubuntu 12, in your linux if its not ubuntu 12 google your specific os to enable root logging via ssh


#5

Hi. I’m the one who wrote cluster_install (and qualify — which is where you are getting hung).

All steps cluster_install takes to install SciDB are done using ssh because it does it as root. So for instance even a local installation will do a number of “ssh root@localhost cp/rm/apt-get/…”

Also yes SciDB and cluster_install work on Ubuntu 14.04

As a start let’s get ssh working for you.
The qualify’er says you have the ssh daemon running locally and port 22 is open.
Also it looks like the qualify’er made you a password-less ssh key pair (id_rsa and id_ras.pub).

So as a first step login (let me know if that is as root, as yourself, as user “scidb”, whatever…).
Then do “ssh localhost date”.

Let me know.


#6

I have tested cluster install yestoday. It does not work if scidb processes are already running on cluster or if postgres running on worker nodes. I had to shutdown all these processes manually.

is there a way to do the install using only scidb and postgres users? or even scidb user by itself by granting to scidb user sudo privs


#7

hadi06: The original post was by hadi06 and I await hadi06’s reply.

senya72: The next release (15.3) with cluster_install will allow installing from an account that has sudo privileges.
Therefor no direct root access will be required.