Postgresql 9.3 seems deprecated

I tried to install SciDB 18.1 and 19.11 on Centos 8 using pre-packaged rpm file.

Both version requires postsql 9.3 exactly, which downloads from https://download.postgresql.org/pub/repos/yum/9.3/

However, the download site download.postgresql.org only support over 9.4 now. So attempts to install postgresql 9.3 have failed.

So it needs to be changed the dependency graph of scidb rpm/deb packages.

Hello @jhan, apologies for the slow response.

CentOS 8 isn’t yet a supported platform. It will be in the near future, but we don’t yet have a timeline for the next release. I’d expect Postgres 9.4 to work fine, or at worst require very minor mods to the SciDB CE source.

We’ve had a series of issues with the package requirements being too restrictive, and this is one of them. We’re doing major work in the packaging area, so going forward we hope to avoid this kind of problem or at least not encounter it so often. In the meantime, thank you for your patience!