No networking in CentOS 6.3 / v13.3 virtual machine?


#1

I’ve been trying to play with the virtual machine posted on the downloads site. Its networking doesn’t appear to start up, regardless of Bridging / NAT / Host-only networking settings. Has anyone gotten the VM up and working? What’s the trick?


#2

Hello,

It might have to do with what version of VirtualBox you are using to run it. Can you tell me that? Did you download the latest 4.2.12 and what’s your Host OS?
I’ll try to figure out what’s going on.


#3

Hi,

I just double-confirmed and made sure everything works fine.
I am using an older, strange version of Virtual Box - 4.1.24 - I need it because I have a macbook with retina display and newer versions don’t play nice. It’s up here: virtualbox.org/wiki/Download_Old_Builds_4_1

This is the first time I actually launched this, but it went about as smooth as it says in the Quick Start guide. It imported fine, I didn’t change any of the settings. It gave me a bit of a hiccup on the first start - so I had to open up “settings” and close it (no actual changes - this is yet another VirtualBox oddity). After that, it came up, and I could log in from another machine on the net…

So… it could be a different Virtual Box version or it could be your host machine? Please tell me more what exactly you’re running on…


#4

Well, we tried it in VirtualBox 4.2.12 on a couple machines, and also porting to VMWare. Same failure mode in all.

Our networking guy did some black magic to get an instance running in VBox this morning, but I’m not sure just what he did.


#5

Understood. Let me know if there’s anything I can do to help.

  • Alex Poliakov

#6

When I start SciDB, it shows me:

Welcome to the SciDB VM!

A simple SciDB web interface is available by directing your browser to:
:8080

This is a weird error. This means the IP is missing. How to solve this error? Please help me out.

By the way, I have tried the steps mentioned in the Quick Start Guide in page 5.


#7

That means that networking between the virtual machine and the host is not working.

You can still log in to the virtual machine and use SciDB and R from the command line terminal. You won’t be able to access SciDB from your web browser on the host machine, or from the RStudio interface though.


#8

I had similar problems with all the modes but NAT. It will basically work as if everything was on the localhost
I put it on NAT to be able to connect host and guest and have access to internet from the guest host.
Then I had to port forward 8080 and 22 (if you have ssh on the vm)


#9

Access from the host to the guest VM worked for me with virtualbox 4.1.12 on ubuntu 12.04, but only, as documented, after setting the network to:

Adapter 1: Intel PRO/1000 MT Desktop (Host-only adapter, ‘vboxnet0’)


#10

Well, in my personal case, I had a similar problem with the virtual machine configuration. Nevertheless, when you know the concepts is an essay task to choose your ideal parameters.
I want to describe the different possibilities to config the virtual machine (with Virtual Box), these alternatives were tested by me.

[ul]Nat: Your virtual machine has Internet (your computer/server give Internet to the virtual machine), own network in the virtual machine.[/ul]
[ul]Nat (redirection port): Your virtual machine has Internet (your computer/server give Internet to the virtual machine), own network in the virtual machine but now, the request that your computer/server receives, these will redirect to your virtual machine (you have to select both ports). [/ul]
[ul]Host only adapter: Your virtual machine stays in a private network, you can access with your computer/server without kind of issue. Although you have not Internet.[/ul]

Probably these doubts are quite easy to find their solution but if you know what problems can generate SciDB, you will anticipate to them. :wink: