Matrix multiplication function not available


#1

Hi,

I found out that the matrix multiplication function (as well as the mad function) is not recognized. Do I need to load a plugin, or need the commercial version?

Thank you,

Stefan


#2

Hi Stefan—
You don’t need the enterprise edition to use matrix multiply. Try loading the ‘linear_algebra’ and ‘dense_linear_algebra’ libraries.

ie

iquery -aq "load_library(‘linear_algebra’)"
iquery -aq “load_library(‘dense_linear_algebra’)”

Once you do this you should have access to the ‘gemm’ operator (general matrix multiply) and the ‘spgemm’ operator (for sparse matrix multiplication).

–Steve F


#3

Thanks, I was missing the info about the sparse package.