Libpqxx library versions conflict while install dev_tools


#1

Hello, all

I got libpqxx library versions conflict while install dev_tools. The epel repository includes newer library versions not compatible with the base CentOS operating system libraries that SciDB is compiled against. In my case, the libpqxx I’m using is version 3.1-1, so I follow the tutorial (https://github.com/Paradigm4/dev_tools) and ran this:
sudo yum install --disablerepo=epel git devtoolset-3-gcc-c++.x86_64 scidb-15.12-libboost-devel libpqxx-devel log4cxx-devel
When I move to the next step and run make in dev_tools directory, got error


Anyone know how to solve this? Thanks

Jingchao


Problem about dev_tools
Convert csv to scidb