Java compatibiilty


#1

Has anyone encountered the following error or similar?:

E: Unable to locate package openjdk-8-jdk

This occurred when I installed the packages on multiple nodes, i.e.:
ubuntu@dfz-scidb-0:~/scidb$ ./deployment/deploy.sh scidb_install /tmp/packages dfz-scidb-0 dfz-scidb-1

Here’s my java version:
ubuntu@dfz-scidb-0:~/scidb$ java -version
openjdk version "1.8.0_91"
OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-0ubuntu4~14.04-b14)
OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

JAVA_HOME:
ubuntu@dfz-scidb-0:~/scidb$ echo $JAVA_HOME
/usr/lib/jvm/java-8-openjdk-amd64

OS:
ubuntu@dfz-scidb-0:~/scidb$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.4 LTS
Release: 14.04
Codename: trusty

Thanks!
Don


#2

I checked the script and error was from the remote node. Installing Java-8 on the remote node fixed the problem.