Issue with installation on Ubuntu SMP: Empty root folder


#1

Hi all,

I am trying to install SCIDB 14.8 on a 64 bit Ubuntu server (Linux 3.13.0-35-generic #62-Ubuntu SMP).
This is my INI config file, generated with the recommended tool at htmlpreview.github.io/?https://r … .14.8.html:

[myscidb] server-0=spatial-center,3 install_root=/opt/scidb/14.8 metadata=/opt/scidb/14.8/share/scidb/meta.sql pluginsdir=/opt/scidb/14.8/lib/scidb/plugins logconf=/opt/scidb/14.8/share/scidb/log4cxx.properties db_user=<a user> db_passwd=<a password> base-port=1239 base-path=/home/scidb/scidb_data redundancy=0 execution-threads=1 result-prefetch-threads=1 result-prefetch-queue-size=1 operator-threads=1

And this is a little Makefile with the bash commands to install it:

[code]
SCIDB_INI=/home/myuser/scidb/scidb-config.ini
CL_INST=/tmp/deployment-14.8/cluster_install
CL_INST_DIR=/tmp/

NOTE: execute this as root with “sudo su”

install_scidb:
adduser scidb
rm -r /opt/scidb/14.8
wget https://github.com/Paradigm4/deployment/archive/14.8.zip
mkdir -p /home/scidb/scidb_data
mkdir -p /opt/scidb/14.8
cp 14.8.zip ${CL_INST_DIR}
cd ${CL_INST_DIR} && sudo unzip 14.8.zip
cd ${CL_INST} && ./cluster_install -u scidb -s ${SCIDB_INI}
# execute “su scidb”
# and then “. ~/.bashrc”

start_scidb:
scidb.py startall cluster[/code]

When I run the installation, everything seems to work fine, until I get:

Script common path: /tmp/deployment-14.8/cluster_install/common
SciDB version: 14.8
Executing: scidb_prepare_wcf scidb spatialscidb spatial-center

export SCIDB_VER=14.8 export PATH=/opt/scidb/$SCIDB_VER/bin:/opt/scidb/$SCIDB_VER/share/scidb:$PATH export LD_LIBRARY_PATH=/opt/scidb/$SCIDB_VER/lib:$LD_LIBRARY_PATH bash: /opt/scidb/14.8/etc/config.ini: No such file or directory

And then the installation terminates normally. However, my /opt/scidb/14.8 directory is empty. Nothing has been downloaded in it, and scidb is clearly not installed.

Any pointer to a fix?

Regards,
Andrea


#2

Hi,
Can you try running cluster_install manually?
cd /tmp/deployment-14.8/cluster_install
./cluster_install -u scidb -s ${SCIDB_INI}

and check that SCIDB_INI really is the config file you posted.

For the output you gave:

Executing: scidb_prepare_wcf scidb spatialscidb spatial-center

the arguments to scidb_prepare_wcf are ${username} “” “${cluster_name}” cat $host_file
which indicates
username=scidb
user_password="" (so it will use sshpass to give the password)
cluster_name=spatialscidb
coordinator=spatial-center
BUT your config file shows cluster_name=myscidb


#3

Thank you for your reply. I just realized that I was trying to install SciDB on Ubuntu 14.04 and not 12.04.
Is there a way to install it on 14.04?

Kind regards,
Mulone


#4

We only build on 12.04 and have not tested nor built on 14.04 - so the quick answer is “unsupported”.

I do not know what would happen if you tried doing the whole install manually (as was in 13.12 and backwards).
The manual did give a step by step manual install at that time.


#5

PS: We are working on porting SciDB to Ubuntu 14.04. Should be available in a few weeks.


#6

Hi Mulone,

We have a few machines with Ubuntu 14.04 LTS as well, wonder what’s the ETA for the port of SciDB 14.8 to Ubuntu 14.04 please? Thanks!

Regards,
Patrick


#7

Hi Patrick,

The next SciDB version – 14.11 will support Ubuntu 14.04.
ETA is end of November 2014.

Regards,
Sunny


#8

Thanks Sunny. Looking forward!


#9

i m facing problem with installing scidb
i m using virtual machine (ubuntu 14.4)
what are the steps to install scidb on that machine


#10

Please visit the page scidb.org/forum/viewtopic.php?f=14&t=1526. Then use the cluster_install script to install scidb on your cluster.