Is Scidb Abandonware?


Like many users I’ve run into issues compiling SCIDB from scratch. Browsing this forum I see that topics go months or years without any answers. Is this project effectively dead?


Hello! :wave: we are real and we’re here :slight_smile:

Alas we don’t always have bandwidth to answer - particularly some questions that have been answered previously and should be searchable - but thanks for a datapoint of feedback. We’ll try to increase responsiveness here.

Our goal is actually to release a next rev in a few weeks. We aim to include Community Edition install packages - that should help take some of the build pain out of the CE install experience.

In addition to the next release, some open projects that P4 is working on now:

  1. new version of SciDB-Py recently released:
  2. integrating TensorFlow with our Streaming interface:
  3. starting to look at the Arrow format:

As far as community projects I’m aware of - I know of quite a few folks working with geography datasets and genomics. Some very interesting C+±level GPU integration work recently. Some folks aren’t as open about what they’re doing…

At any rate - let us know if we can help!

Upload Numpy Array to SciDB keeping the Numpy Array's indices

i had compiled 3 versions of scidb recently on ubuntu 14 as part of my loadTiff operator unit testing
16.9, 15.12, 15.7 - no issues with compilation. i had found an user-defined function API changed between 15.7 and 15.12 but that a diff story


I’ve tried compiling 16.9, and 15.7 on CentOS 6 and 7 but no luck so far. Maybe it’s my choice of Linux :frowning:


Hi @anthonybsd! What kinds of compilation and installation challenges have you encountered?


Trying to compile 15.12 now.
Getting this with Cmake. deploy prepare_toolchain completed successfully. I’ve tried searching here for a similar error to no avail:

`./ setup WARNING: Deleting old CMakeCache file:/opt/scidb/scidb-
WARNING: about to delete all contents of /opt/scidb/scidb-* [y]|n: y
– ****************** BEGIN CMakeLists.txt ******************
– The C compiler identification is GNU 4.9.2
– The CXX compiler identification is GNU 4.9.2
– The Fortran compiler identification is GNU
– Check for working C compiler: /opt/rh/devtoolset-3/root/usr/bin/gcc
– Check for working C compiler: /opt/rh/devtoolset-3/root/usr/bin/gcc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Check for working CXX compiler: /opt/rh/devtoolset-3/root/usr/bin/g++
– Check for working CXX compiler: /opt/rh/devtoolset-3/root/usr/bin/g++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Check for working Fortran compiler: /opt/rh/devtoolset-3/root/usr/bin/gfortran
– Check for working Fortran compiler: /opt/rh/devtoolset-3/root/usr/bin/gfortran – works
– Detecting Fortran compiler ABI info
– Detecting Fortran compiler ABI info - done
– Checking whether /opt/rh/devtoolset-3/root/usr/bin/gfortran supports Fortran 90
– Checking whether /opt/rh/devtoolset-3/root/usr/bin/gfortran supports Fortran 90 – yes
– CMAKE_INSTALL_PREFIX not Initialized to default keeping: /opt/scidb/scidb-
– Found Git: /usr/bin/git (found version “1.7.1”)
– Reading revision from file: 4cadab5
– Build type (use -DCMAKE_BUILD_TYPE=[RelWithDebInfo]/Debug/Release/Profile/CC/Valgrind): Debug
CMake Error at cmake/Modules/LinuxDistroVersion.cmake:36 (if):
if given arguments:

"STREQUAL" "Red Hat"

Unknown arguments specified
Call Stack (most recent call first):
CMakeLists.txt:112 (include)

– Configuring incomplete, errors occurred!
See also “/opt/scidb/scidb-”. ERROR: Command setup failed: Abnormal return code: 1 on command [‘cmake’, ‘-DCMAKE_BUILD_TYPE=Debug’, ‘-DCMAKE_INSTALL_PREFIX=/opt/scidb/scidb-’, ‘/opt/scidb/scidb-’] ERROR: Make sure commands setup,make,install,start are performed (in that order) before stop,stopForce,tests`


Can you please supply the environment variables that you have set when you execute setup? The output of env would be sufficient. Thanks!


Here’s the output. I’ve omitted HOSTNAME (company-specific info):

LESSOPEN=||/usr/bin/ %s


Thank you for sending that along. After doing a bit of digging on my end, I need a few more pieces from you. Can you send me the contents of /etc/issue as well as the output of uname -s and the contents of /etc/redhat-release? Thanks!


Sent in a forum message. Thanks for your help!


I received your reply, thank you for sending it and the content of /etc/issue. I believe the problem is with the content of /etc/issue which in your case appears to have some administrative text in it. On my system, /etc/issue appears as

CentOS release 6.9 (Final)
Kernel \r on an \m

The LinuxDistroVersion.cmake script inspects /etc/issue to determine information about the distribution of Linux running on the system. Since it doesn’t find what it’s looking for in your file, due to the presence of that administrative text, the script fails. I’m not sure how much control you have over your machine, but you could try backing-up your current /etc/issue and placing one with contents similar to mine above (matching your distro of linux). In your case, based on the message that you sent, you could try:

CentOS release 6.7 (Final)
Kernel \r on an \m


That did it. Thank you so much!


yes you need to install gcc 4.4.9 via scl (software collections) or above on centos. scidb needs c++ 11 compiler (read scidb install instructions and prereqs in CE installation document)and that only supported with 4.4.9 or abve. yes its your choice of linux nothing to do with scidb, once you install compiler you will be all set on centos as well. the scl is the centos answer to redhat enterprise repo.
this is more of an issue with centos than anything to whatsoever with scidb or your claim that scidb is dead. if you try to compile any c++ 11 code on centos it will fail as well. here is convinient link for you i had googled



dgosselin, should scidb cmake file use more robust way to determine linux distro?
like ones described here


Just adding a note – the next release of scidb will have the ability to install from packages in the community edition. So at least for the OS-es we officially cover, the install pain will go away.

Do keep the discussion going @senya72 and @dgosselin – it is very valuable. BTW thanks @anthonybsd for spawning the discussion :slight_smile:


Thanks @Kriti_Sen_Sharma! @senya72, yes, we’re going to look at more robust ways of detecting the target distro, thank you for sending that information along!


@anthonybsd, glad to hear it!


well ideally p4 will allow contributions to community edition, now it made steps to add normal installer to CE. this issue with instllation on centos woud been fixed long ago by community. the issue with scl devtools on centos would been mentioned in release notes as well