Installing using RHEL package


#1

I am having trouble installing scidb using the binary package repository. It is having trouble with the mpich package requirement. I tried installing mpich, but it installed a version (mpich-3.1-4.el6.x86_64) which did not satisfy the dependency. I am using RHEL 6.6–actually, I suspect that this may be the problem, the update from 6.5 to 6.6 just happened very recently. Any help would be great.

Thanks,
David.

[ul]
[color=#400080]root@hpc085 ~ #[/color] wget downloads.paradigm4.com/key
–2014-11-04 17:01:56-- downloads.paradigm4.com/key
Resolving downloads.paradigm4.com… 74.50.61.106
Connecting to downloads.paradigm4.com|74.50.61.106|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 1699 (1.7K) [text/plain]
Saving to: “key”

100%[==================================================================================================================================================================================================>] 1,699 --.-K/s in 0s

2014-11-04 17:01:56 (277 MB/s) - “key” saved [1699/1699]

[color=#400080]root@hpc085 ~ #[/color] rpm --import key
[color=#400080]root@hpc085 ~ #[/color] rm -f key
[color=#400080]root@hpc085 ~ #[/color] emacs /etc/yum.repos.d/scidb.repo
[color=#400080]root@hpc085 ~ #[/color] yum clean all
Loaded plugins: product-id, rhnplugin, security, subscription-manager
Cleaning repos: epel rhel-x86_64-server-6 rhel-x86_64-server-6-rhscl-1 rhel-x86_64-server-6-rhscl-1-debuginfo rhel-x86_64-server-6-thirdparty-oracle-java rhel-x86_64-server-fastrack-6 rhel-x86_64-server-fastrack-6-debuginfo
: rhel-x86_64-server-optional-6 rhel-x86_64-server-optional-6-debuginfo rhel-x86_64-server-optional-fastrack-6 rhel-x86_64-server-optional-fastrack-6-debuginfo rhel-x86_64-server-rh-common-6
: rhel-x86_64-server-rh-common-6-debuginfo rhel-x86_64-server-supplementary-6 rhn-tools-rhel-x86_64-server-6 scidb
Cleaning up Everything
[color=#400080]root@hpc085 ~ #[/color] yum update
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Update Process
epel/metalink | 14 kB 00:00
epel | 4.4 kB 00:00
epel/primary_db | 6.3 MB 00:31
rhel-x86_64-server-6 | 1.8 kB 00:00
rhel-x86_64-server-6/primary | 19 MB 00:04
rhel-x86_64-server-6 14233/14233
rhel-x86_64-server-6-rhscl-1 | 1.6 kB 00:00
rhel-x86_64-server-6-rhscl-1/primary | 672 kB 00:00
rhel-x86_64-server-6-rhscl-1 2483/2483
rhel-x86_64-server-6-rhscl-1-debuginfo | 1.6 kB 00:00
rhel-x86_64-server-6-rhscl-1-debuginfo/primary | 34 kB 00:00
rhel-x86_64-server-6-rhscl-1-debuginfo 197/197
rhel-x86_64-server-6-thirdparty-oracle-java | 1.6 kB 00:00
rhel-x86_64-server-6-thirdparty-oracle-java/primary | 71 kB 00:00
rhel-x86_64-server-6-thirdparty-oracle-java 237/237
rhel-x86_64-server-fastrack-6 | 1.2 kB 00:00
rhel-x86_64-server-fastrack-6/primary | 36 kB 00:00
rhel-x86_64-server-fastrack-6 108/108
rhel-x86_64-server-fastrack-6-debuginfo | 1.2 kB 00:00
rhel-x86_64-server-fastrack-6-debuginfo/primary | 129 B 00:00
rhel-x86_64-server-optional-6 | 1.8 kB 00:00
rhel-x86_64-server-optional-6/primary | 1.9 MB 00:00
rhel-x86_64-server-optional-6 8063/8063
rhel-x86_64-server-optional-6-debuginfo | 1.6 kB 00:00
rhel-x86_64-server-optional-6-debuginfo/primary | 636 kB 00:00
rhel-x86_64-server-optional-6-debuginfo 3463/3463
rhel-x86_64-server-optional-fastrack-6 | 1.2 kB 00:00
rhel-x86_64-server-optional-fastrack-6/primary | 9.4 kB 00:00
rhel-x86_64-server-optional-fastrack-6 39/39
rhel-x86_64-server-optional-fastrack-6-debuginfo | 1.2 kB 00:00
rhel-x86_64-server-optional-fastrack-6-debuginfo/primary | 129 B 00:00
rhel-x86_64-server-rh-common-6 | 1.6 kB 00:00
rhel-x86_64-server-rh-common-6/primary | 8.2 kB 00:00
rhel-x86_64-server-rh-common-6 32/32
rhel-x86_64-server-rh-common-6-debuginfo | 1.6 kB 00:00
rhel-x86_64-server-rh-common-6-debuginfo/primary | 1.0 kB 00:00
rhel-x86_64-server-rh-common-6-debuginfo 3/3
rhel-x86_64-server-supplementary-6 | 1.8 kB 00:00
rhel-x86_64-server-supplementary-6/primary | 147 kB 00:00
rhel-x86_64-server-supplementary-6 407/407
rhn-tools-rhel-x86_64-server-6 | 1.6 kB 00:00
rhn-tools-rhel-x86_64-server-6/primary | 26 kB 00:00
rhn-tools-rhel-x86_64-server-6 146/146
scidb | 951 B 00:00
scidb/primary | 21 kB 00:00
scidb 89/89
No Packages marked for Update
[color=#400080]root@hpc085 ~ #[/color] yum install scidb-14.8-all
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
–> Running transaction check
—> Package scidb-14.8-all.x86_64 0:0-7978 will be installed
–> Processing Dependency: scidb-14.8-utils = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Processing Dependency: libscidbclient-14.8-python = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Processing Dependency: libscidbclient-14.8 = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Processing Dependency: scidb-14.8-doc = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Processing Dependency: scidb-14.8 = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Processing Dependency: scidb-14.8-plugins = 0-7978 for package: scidb-14.8-all-0-7978.x86_64
–> Running transaction check
—> Package libscidbclient-14.8.x86_64 0:0-7978 will be installed
—> Package libscidbclient-14.8-python.x86_64 0:0-7978 will be installed
—> Package scidb-14.8.x86_64 0:0-7978 will be installed
–> Processing Dependency: scidb-14.8-libboost-system = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: scidb-14.8-libboost-program-options = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: scidb-14.8-libboost-thread = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: scidb-14.8-libboost-filesystem = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: scidb-14.8-libboost-regex = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: scidb-14.8-libboost-serialization = 1.54.0-0 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: postgresql < 8.5 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: postgresql >= 8.4 for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: python-argparse for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: mpich2 for package: scidb-14.8-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
–> Processing Dependency: libboost_thread.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libpqxx-3.1.so()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_serialization.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: liblog4cxx.so.10()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_date_time.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_regex.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_system.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_program_options.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libboost_filesystem.so.1.54.0()(64bit) for package: scidb-14.8-0-7978.x86_64
–> Processing Dependency: libprotobuf.so.7()(64bit) for package: scidb-14.8-0-7978.x86_64
—> Package scidb-14.8-doc.noarch 0:0-7978 will be installed
—> Package scidb-14.8-plugins.x86_64 0:0-7978 will be installed
–> Processing Dependency: libmpichcxx.so.1.2()(64bit) for package: scidb-14.8-plugins-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
–> Processing Dependency: libmpich.so.1.2()(64bit) for package: scidb-14.8-plugins-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
—> Package scidb-14.8-utils.x86_64 0:0-7978 will be installed
–> Running transaction check
—> Package libpqxx.x86_64 0:3.1-1 will be installed
—> Package log4cxx.x86_64 0:0.10.0-13.el6 will be installed
—> Package postgresql.x86_64 0:8.4.20-1.el6_5 will be installed
—> Package protobuf.x86_64 0:2.4.1-2 will be installed
—> Package python-argparse.noarch 0:1.2.1-2.1.el6 will be installed
—> Package scidb-14.8.x86_64 0:0-7978 will be installed
–> Processing Dependency: mpich2 for package: scidb-14.8-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
—> Package scidb-14.8-libboost-date-time.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-filesystem.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-program-options.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-regex.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-serialization.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-system.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-libboost-thread.x86_64 0:1.54.0-0 will be installed
—> Package scidb-14.8-plugins.x86_64 0:0-7978 will be installed
–> Processing Dependency: libmpichcxx.so.1.2()(64bit) for package: scidb-14.8-plugins-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
–> Processing Dependency: libmpich.so.1.2()(64bit) for package: scidb-14.8-plugins-0-7978.x86_64
Package mpich2 is obsoleted by mpich, but obsoleting package does not provide for requirements
–> Finished Dependency Resolution
Error: Package: scidb-14.8-plugins-0-7978.x86_64 (scidb)
Requires: libmpichcxx.so.1.2()(64bit)
Available: mpich2-1.2.1-2.3.el6.x86_64 (rhel-x86_64-server-6)
libmpichcxx.so.1.2()(64bit)
Available: mvapich2-1.6-3.el6.x86_64 (rhel-x86_64-server-6)
libmpichcxx.so.1.2()(64bit)
Available: mvapich2-psm-1.6-3.el6.x86_64 (rhel-x86_64-server-6)
libmpichcxx.so.1.2()(64bit)
Available: mvapich2-1.4-5.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-1.8-1.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-2.0rc1-1.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-1.4-5.el6.x86_64 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-1.8-1.el6.x86_64 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-2.0rc1-1.el6.x86_64 (rhel-x86_64-server-6)
Not found
Error: Package: scidb-14.8-plugins-0-7978.x86_64 (scidb)
Requires: libmpich.so.1.2()(64bit)
Available: mpich2-1.2.1-2.3.el6.x86_64 (rhel-x86_64-server-6)
libmpich.so.1.2()(64bit)
Available: mvapich2-1.6-3.el6.x86_64 (rhel-x86_64-server-6)
libmpich.so.1.2()(64bit)
Available: mvapich2-psm-1.6-3.el6.x86_64 (rhel-x86_64-server-6)
libmpich.so.1.2()(64bit)
Available: mvapich2-1.4-5.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-1.8-1.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-2.0rc1-1.el6.i686 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-1.4-5.el6.x86_64 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-1.8-1.el6.x86_64 (rhel-x86_64-server-6)
Not found
Available: mvapich2-psm-2.0rc1-1.el6.x86_64 (rhel-x86_64-server-6)
Not found
Error: Package: scidb-14.8-0-7978.x86_64 (scidb)
Requires: mpich2
Available: mpich2-1.2.1-2.3.el6.i686 (rhel-x86_64-server-6)
mpich2 = 1.2.1-2.3.el6
You could try using --skip-broken to work around the problem
[color=#400080]root@hpc085 ~ #[/color] uname -a
Linux hpc085.mbc.com 2.6.32-431.29.2.el6.x86_64 #1 SMP Sun Jul 27 15:55:46 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
[color=#400080]root@hpc085 ~ #[/color] cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.6 (Santiago)
[/ul]


#2

Hi David,

Yes I think you are running into this: viewtopic.php?f=19&t=1477
It looks like we’re very close to a solution – ETA on update 48 hours.


#3

Thank you for your quick response. I’m glad to know you’re working on it. I will look for the fix in a couple of days, and try again…
Thanks again,
David.


#4

Should be fixed now.