Installing SciDb Ubuntu 10.10


#1

Hi,

Apologies for the simplicity of the question. I looked through the doc though and could not find an answer.

After installing the sources and compiling them I installed scidb 0.75 fine. I then ran the prepare script for the postgres catalog and all went fine.

Following the doc, I then tried to run init on the db and got this error:
scidb@ubuntu:~$ scidb init scidb
One of program options required but value not set or value is empty. You can set this option with next way(s):

  • Through command line argument -c (–catalog)
  • Through config variable ‘CATALOG’

terminate called after throwing an instance of 'std::string’
Aborted

What am I missing ?

Thanks a lot
jean safar


#2

Hello Jean,

As per the error message, it says it needs a catalog string. This string is emitted by the “setup postgres” step.
Looks something like this:
scidb -c “host=localhost port=5432 dbname=mydb user=mydb password=mydb”

I also hope that the alias name “scidb” does not run into a conflict with the executable name “scidb”.

For reference, here’s a step-by-step sequence that has worked in the past:
viewtopic.php?f=11&t=17#p192


#3

Thanks a lot.

After running the scidb-prepare and putting it in the scidb command it still can’t find the catalog. It says:

What(): Storage is not defined in system catalog.

I checked that postgres is up and the schemas are created. Any other verifications I can make ?

thanks in advance


#4

Interestingly, I can’t find that error message in the source. We do have an error message that says “Storage is not registered in system catalog.” Did you mistype or am I looking in the wrong place?

If you are getting the “Storage is not registered” error, then there could be a problem with catalog tables or storage system initialization, and the scidb.log will provide more details.

Have you tried the installation steps in the link I attached above? At worst case I suppose we could start over.


#5

Just to double check and make sure our instructions are clear.

Make sure you go through the init scripts if possible, and that
requires sudo permissions. That procedure for R0.75 is documented
here:

trac.scidb.org/wiki/Docs/Release … stallGuide

The init command should be
scidb-0.7.5 init
Where is the section name in the config.ini.
So steps to check are:

  • Did the config.ini get created properly and placed in the right place.
  • And the script name for init is scidb-0.7.5 not scidb

Let me know if you are able to get it up and running successfully.


#6

Alex,

Thanks so much. I eventually was using the wrong executable (scidb in bin) instead of scidb-0.7.5 which I found in share/bin

So now it almost works (just need to enable my account for sudo on postgres …)

Thanks a lot again.
jean


#7

Hi all,

I think I met the same problem with Alex.

After running the scidb-prepare, I try “scidb init test -c …” It says:

“What(): Storage is not defined in system catalog.”

But I am using SciDB 11.06 on a Debian system. I can not find where is “scidb-0.7.5”… there’s no share/bin folder…

Now my database can not be initialized…

Best,
Xiaowei