Install on Fedora 12 (x86_64)


#1

Hello

After a successful build of SciDB from the svn trunk, I have this error during the set up of the postgres catalog etc:

psql:/tmp/meta.sql:100: NOTICE: CREATE TABLE / UNIQUE will create implicit index "libraries_name_key" for table "libraries" CREATE TABLE psql:/tmp/meta.sql:105: ERROR: could not access file "$libdir/uuid-ossp": No such file or directory psql:/tmp/meta.sql:107: ERROR: function uuid_generate_v1() does not exist LINE 1: insert into "cluster" values (uuid_generate_v1()); ^ <<<

I ran the commands in scidb-prepare-db.sh manually due to permissions issues.
Perhaps this may have caused it.

Had a quick hunt round for “$libdir” but nothing seems obvious to interpolate it

Giles


#2

$libdir is the directory where postgresql keeps shared objects.

Did you install postgresql yourself? I’m not sure if that was the reason, but I ran into this when installing scidb on my own build of postgresql-9.0.1. I got past it by doing the following:

  • install OSSP uuid library from ossp.org/pkg/lib/uuid/
  • re-configure postgresql source tree using --with-ossp-uuid
  • make ; make install in postgresql/contrib subdirectory

– Dave


#3

Did you install postgresql yourself?

No, I just went for the bog-standard yum rpm

Thanks

Giles


#4

try yum install postgresql-contrib

– Dave


#5

try yum install postgresql-contrib

Sorted, thanks Dave.


#6

How do I make Fedora download 3rd party software? I can’t seem to install mp3 support for Fedora or any software that’s not made by Fedora developers. How do I let Fedora download and install install 3rd party software just like changing the software sources in Ubuntu?