Install from source


#1

Hi, i’m trying to install scidb on my ubuntu 12.04 i386 system. But i’ve encountered so many errors after cmake .
I’m new to this field, could anyone help me solve the problems?

[code]jiong@ubuntu:~/SCIDB/scidb-12.3.0.4813-Snowdrop-final$ cmake .
– CMAKE_INSTALL_PREFIX not Initialized to default keeping: /usr/local
– Reading revision from file: 4813
– Build type (use -DCMAKE_BUILD_TYPE=[RelWithDebInfo]/Debug/Release/Profile/CC):
DISTRO_NAME_VER is Ubuntu-12.04
– GPB - /usr/lib/libprotobuf.so
– LOG4CXX - /usr/lib/liblog4cxx.so
CMake Error at cmake/Modules/FindLibPQ.cmake:49 (string):
string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
command.
Call Stack (most recent call first):
CMakeLists.txt:155 (find_package)

CMake Error at cmake/Modules/FindLibPQ.cmake:50 (string):
string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
command.
Call Stack (most recent call first):
CMakeLists.txt:155 (find_package)

CMake Error at cmake/Modules/FindLibPQ.cmake:55 (string):
string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
command.
Call Stack (most recent call first):
CMakeLists.txt:155 (find_package)

CMake Error at cmake/Modules/FindLibPQ.cmake:56 (string):
string sub-command REGEX, mode REPLACE needs at least 6 arguments total to
command.
Call Stack (most recent call first):
CMakeLists.txt:155 (find_package)

CMake Error at /usr/local/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
Could NOT find LibPQ (missing: LIBPQ_LIBRARIES_DIRS LIBPQ_INCLUDE_DIRS)
Call Stack (most recent call first):
/usr/local/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
cmake/Modules/FindLibPQ.cmake:62 (find_package_handle_standard_args)
CMakeLists.txt:155 (find_package)

– Configuring incomplete, errors occurred!
[/code]


#2

The libpqxx-3.1 package is required for Ubuntu 12.04 (which replaces libpqxx-3.0 in earlier releases of Ubuntu).
Below is a detailed list of required packages.

sudo apt-get install -y build-essential cmake libboost1.42-all-dev postgresql-8.4
libpqxx-3.1 libpqxx3-dev libprotobuf7 libprotobuf-dev protobuf-compiler doxygen
flex bison libxerces-c-dev libxerces-c3.1 liblog4cxx10 liblog4cxx10-dev
libcppunit-1.12-1 libcppunit-dev libbz2-dev postgresql-contrib-8.4
libconfig++8 libconfig++8-dev libconfig8-dev subversion
libreadline6-dev libreadline6 python-paramiko python-crypto xsltproc liblog4cxx10-dev