Failed to fetch Sources


#1

Good morning,

I tried to install SciDB 14.8 using:

wget https://github.com/Paradigm4/deployment/archive/14.8.zip
unzip 14.8.zip
cd /root/deployment-14.8/cluster_install
yes | ./cluster_install -s /home/scidb/scidb_docker_8.ini

This have worked many times before, but now I am getting this error message:

(...)
Ign http://downloads.paradigm4.com ubuntu12.04/14.8/ Release.gpg
Ign http://downloads.paradigm4.com ubuntu12.04/14.8/ Release
Err http://downloads.paradigm4.com ubuntu12.04/14.8/ Sources
  Undetermined Error
Err http://downloads.paradigm4.com ubuntu12.04/14.8/ Packages
  Undetermined Error
W: Failed to fetch http://downloads.paradigm4.com/ubuntu12.04/14.8/Sources  Undetermined Error

W: Failed to fetch http://downloads.paradigm4.com/ubuntu12.04/14.8/Packages  Undetermined Error

E: Some index files failed to download. They have been ignored, or old ones used instead.

Could something be wrong with Paradigm4 repositories?

Kind regards.


#2

Please download the cluster installer from the master trunk on github and re-run the installation.


#3

I found the problem: the server was missing a package:

sudo apt-get install apt-transport-https

Now the script is working again. Thanks for your answer, it helped me to find the problem.

Kind regards.


#4

I’ve had a similar problem with using the “http://downloads.paradigm4.com/” url in apt sources recently. It redirects to the https version, “https://downloads.paradigm4.com/”, so if you use that url then it works fine.