Error when i just use '' scidb.py initall db"


#1

it says that:

/opt/scidb/14.3/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 No authentication methods available
[scidb@Coordinate ~]$ /opt/scidb/14.3/bin/scidb.py initall FATE
Found 0 scidb processes
This will delete all data and reinitialize storage [n]|y: y
init(server 0 (localhost) local instance 0)
Initializing local scidb instance/storage.

Cleaning up old logs and storage files.
Removing data directory /home/scidb/DB-FATE/000/0 on server 0 (localhost), local instance 0
init(server 1 (worker1) local instance 1)
Initializing local scidb instance/storage.

Cleaning up old logs and storage files.
Removing data directory /home/scidb/DB-FATE/001/1 on server 1 (worker1), local instance 1
/opt/scidb/14.3/bin/scidb.py: ERROR: Remote command exception:
exec /bin/bash -c $'cd /home/scidb/DB-FATE/001/1;/opt/scidb/14.3/bin/scidb --register -p 1240 -i worker1 -s /home/scidb/DB-FATE/001/1/storage.cfg -l /opt/scidb/14.3/share/scidb/log4cxx.properties --rle-chunk-format=True -c \'host=localhost port=5432 dbname=FATE user=fate password=fate\' 1> init-stdout.log 2> init-stderr.log'
Abnormal return code: 1 stderr:

i just install tht version 14.3 on centos 6.4 and i haven’t install scidb before. the virtual software i use is VMWare Station9 on win7. NAT static IP

thank you !!!


#2

my config file is:

[color=#FF0040][FATE]
server-0=localhost,0
server-1=worker1,1
server-2=worker2,1
db_user=fate
db_passwd=fate
install_root=/opt/scidb/14.3
pluginsdir=/opt/scidb/14.3/lib/scidb/plugins
logconf=/opt/scidb/14.3/share/scidb/log4cxx.properties
base-path=/home/scidb/DB-FATE
tmp-path=/tmp
base-port=1239
interface=eth0
no-watchdog=false[/color]


#3
psql (8.4.20)
Type "help" for help.

postgres=# select version()
postgres-# ;
                                                     version

--------------------------------------------------------------------------------
----------------------------------
 PostgreSQL 8.4.20 on x86_64-redhat-linux-gnu, compiled by GCC gcc (GCC) 4.4.7 2
0120313 (Red Hat 4.4.7-4), 64-bit
(1 row)

postgres=#

#4

I suspect that the problem is that you’ve not installed the OpenSSL correctly. That’s what the “/opt/scidb/14.3/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 No authentication methods available” error message is all about.

Have a look at the installation docs, and especially the section on setting up ssh. SciDB runs on a cluster. And for better or for worse, setting up authentication between physical nodes on a cluster is a complex little operation.


#5

[quote=“plumber”]I suspect that the problem is that you’ve not installed the OpenSSL correctly. That’s what the “/opt/scidb/14.3/bin/scidb.py: ERROR: ssh failure: server=localhost port=22 No authentication methods available” error message is all about.

Have a look at the installation docs, and especially the section on setting up ssh. SciDB runs on a cluster. And for better or for worse, setting up authentication between physical nodes on a cluster is a complex little operation.[/quote]

when i type “ssh woker1” it works . that indicates openssl installed correctly.

[color=#FF0000]in worker1 scdib.log said "
2014-04-15 10:05:39,502 [0x7f34c7e11840] [DEBUG]: Created temp directory /home/scidb/DB-FATE/001/1/tmp/
2014-04-15 10:05:39,503 [0x7f34c7e11840] [ERROR]: System catalog connection failed: SystemException in file: src/system/catalog/SystemCatalog.cpp function: connect line: 2053
Error id: scidb::SCIDB_SE_SYSCAT::SCIDB_LE_CANT_CONNECT_PG
Error description: System catalog error. Cannot connect to PostgreSQL catalog: 'could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432?
could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432? "[/color]
and the [color=#FF4000]postgresql.conf is

"# - Connection Settings -

listen_addresses = ‘’ # what IP address(es) to listen on;
# comma-separated list of addresses;
# defaults to ‘localhost’, '
’ = all
# (change requires restart)
port = 5432 # (change requires restart)
max_connections = 100 # (change requires restart)

[/color]

[color=#FF0000]the pg_hba.conf is "

“local” is for Unix domain socket connections only

local all all trust

IPv4 local connections:

host all all 127.0.0.1/32 trust
host all all 0.0.0.0/0 trust
#host all all 192.168.109.104 255.255.255.0 trust
#host all all 192.168.109.105 255.255.255.0 trust
host all all 192.168.109.0/24 trust

IPv6 local connections:

host all all ::1/128 trust

"[/color]


#6

[color=#FF0000]I just think of pg error

[color=#FF0040]Solved it .modify config.ini use IP address replace "localhost"
Also ,i change the type of network from vmnet8(NAT) to bridge
and that is OK
plumber
you are right! Thanks. [/color][/color]


#7

I have the exact same problem… My pg_hba.conf and postgresql.conf is correctly set.
Any help is very much appreciated.


#8

[quote=“sohn1392”][quote]
Error id: scidb::SCIDB_SE_SYSCAT::SCIDB_LE_CANT_CONNECT_PG
Error description: System catalog error. Cannot connect to PostgreSQL catalog: 'could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432?
could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432? "
[/quote]

I have the exact same problem… My pg_hba.conf and postgresql.conf is correctly set.
Any help is very much appreciated.[/quote]
can you show me your config.ini and pg version

i also modified the /etc/hosts file on each node


#9

[quote=“sohn1392”][quote]
Error id: scidb::SCIDB_SE_SYSCAT::SCIDB_LE_CANT_CONNECT_PG
Error description: System catalog error. Cannot connect to PostgreSQL catalog: 'could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432?
could not connect to server: Connection refused
Is the server running on host “localhost” and accepting
TCP/IP connections on port 5432? "
[/quote]

I have the exact same problem… My pg_hba.conf and postgresql.conf is correctly set.
Any help is very much appreciated.[/quote]
xx
i guess your config.ini may have some error or your pg_hba.conf xx.xx.xx.xx/yy error


Abnormal return code 1 stderr on -- look at scidb logs for hints