Error in documentation: Installing Scidb 13.6 on Ubuntu 12.0


#1

The documentation results in the following error when trying to install on Ubuntu version 12.04.

root@45b228be507f:/# apt-get install scidb-13.6-all-coord
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
scidb-13.6-all-coord : Depends: scidb-13.6 (= 0-6358) but it is not going to be installed
Depends: libscidbclient-13.6 (= 0-6358) but it is not going to be installed
Depends: scidb-13.6-utils (= 0-6358) but it is not going to be installed
Depends: scidb-13.6-plugins (= 0-6358) but it is not going to be installed
Depends: libscidbclient-13.6-python (= 0-6358) but it is not going to be installed
Depends: postgresql-client-8.4 but it is not installable
Depends: postgresql-8.4 but it is not installable
Depends: postgresql-contrib-8.4 but it is not installable
E: Unable to correct problems, you have held broken packages.


#2

I had trouble installing 13.6 on Linux MInt 15 which is Ubuntu based because there was an inconsistency with the packages, too. So I had to use the ready Virtualbox image of 13.3 on CentOS…


#3

I second michael.kane’s problem above. Is there a fix for the Ubuntu 12.04 dependencies?
Thank you.


#4

Hey guys,

We’ve tried this several times and we can’t see the problem you are seeing. We tried a clean Ubuntu 12.04 VM, we also tried pre-installing Postgres 9 or Postgres 8.4 and it works for us every time. Ubuntu 12.10 is not supported.
A few things to try:

  • try the new 13.9 release as there have been packaging changes
  • try to install package scidb-13.9-all and then install Postgres separately

Please keep us posted on this.


#5

OK, I’ll try again. Thanks for following up.


#6

I am getting the same error while installing scidb-14.3. Was this issue resolved??


#7

To install SciDB, there are a lot of dependency packages, and the machines in the cluster have to be prepared carefully (passwordless SSH, Postgres, etc.) The best way is to use the cluster_install tool from github.com/paradigm4/deployment. Let us know if you have problem installing using the tool.