Disable echo back for loading


#1

Hi experts,

Whenever I try to do a load in iquery, the command prints out what is loaded. E.g. if I do the following sequence to reproduce the “Simple Loading” example from the SciDB user manual (12.3), the loading step prints out not only loaded data, but also a bunch of empty cells. I guess it’s padding for the chunk.

Is there a way I can disable the print out when loading?

Thanks

-Yushu

PS: you can copy&past

cat > num_data.csv << EOF
val,err
1.48306e+09,1
5.80814e+08,1
1.51079e+09,1
1.16154e+09,1
1.42655e+09,1
1.06341e+09,1
EOF

csv2scidb -s 1 -p N < num_data.csv > num_data.scidb    

iquery -q "CREATE ARRAY num_data <val:double,err:double>[i]; "
		 	 	 		
iquery -q "LOAD num_data FROM \"$PWD/num_data.scidb\";"

iquery -q "LOAD num_data FROM '$PWD/num_data.scidb';"
[(1.48306e+09,1),(5.80814e+08,1),(1.51079e+09,1),(1.16154e+09,1),(1.42655e+09,1),(1.06341e+09,1),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),(),... … … … lots of them

#2

Hi Yushu,

Yes, it can be annoying and very impractical for large loads. Use the “-n” flag to iquery which means “do not fetch results”.

I.e.
"iquery -anq “load(foo, ‘/path/to/foo/data’)”