Debian testing


#1

Will the unbuntu package for scidb 12.10 not install on debian testing, or are there some tweaks I can make to allow it to install?

Is the .deb package source available somewhere that I can create a debian testing compatible package?

-Whit

warmstrong@krypton:~$ sudo apt-get install scidb
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
scidb : Depends: libboost-filesystem1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-program-options1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-regex1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-serialization1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libboost-system1.46.1 (>= 1.46.1-1) but it is not installable
Depends: libc6 (>= 2.14) but 2.13-35 is to be installed
Recommends: postgresql-client-8.4 but it is not installable
E: Unable to correct problems, you have held broken packages.
warmstrong@krypton:~$ dpkg --get-selections|grep libboost-filesystem
libboost-filesystem1.46.1 deinstall
libboost-filesystem1.48.0 deinstall
libboost-filesystem1.49-dev install
libboost-filesystem1.49.0 install
warmstrong@krypton:~$


#2

Hi!
I’m not sure about debian testing, it was tested only on Ubuntu 12.04. You can download source deb package with:

sudo apt-get source scidb

tweak it and try to rebuild.


#3

Thanks, Artyom.

What’s the story w/ the postgres 8.4 dependency?

We already have postgres 9.1 running on a separate server. can we use 9.1 as the coordination server?

-Whit


#4

[quote=“armstrtw”]Thanks, Artyom.

What’s the story w/ the postgres 8.4 dependency?

We already have postgres 9.1 running on a separate server. can we use 9.1 as the coordination server?

-Whit
[/quote]

SciDB should work with PG 9.1. I remember I’ve made some changes to support it sometimes ago. But remember SciDB 12.10 was tested primarily with PG 8.4 so PG 9.1 (and other deps/versions) not supported officially yet. Also note libpqxx dependency: we don’t added support for pqxx 4 yet, but seems pqxx 3 should work with PG 9 without problems.