Convert csv to scidb


I am new in using SciDb. I am trying to load data from csv to scidb, but there is no csv2scidb tool in v15.7 which is I am using. I tried to install “accelerated_io_tools”, but I am unable to install it as it is giving me error like following:
LogicalSplit.cpp:61:89: error: ‘class scidb::Query’ has no member named ‘getDefaultArrayResidency’
return ArrayDesc(“split”, attributes, dimensions, defaultPartitioning(), query->getDefaultArrayResidency());
There are many errors like above while installing “accelerated_io_tools”.

Is there any way to load my csv data (huge csv file larger than 5gb) to scidb.


Yes, they removed that csv2scidb.
Here is the operator for 15.12, for 15.7 probably the same.
Also, if you want to use accelerated_io_tools, you need
However, I got some probles when I was trying to install this dev_tools,a dn haven’t solved yet
Libpqxx library versions conflict while install dev_tools
But you can always use the very basic load operator to load your data.


Thank you for the answer.
I loaded the data using basic load operator, but the thing is the rows begin to print once load is completed. Is there any way to stop this?


with this command you do not see the lists …
AFL% set no fetch;

to revert just say:

AFL% set fetch;