Can't connect remote postgres server


#1

I’m trying to deploy SciDB on two EC2 instances following the official instruction. The two nodes’ hostnames are dfz-scidb-0 (IP: 172.31.9.91) and dfz-scidb-1 (IP: 172.31.9.92).

Everything looked good until I tried to “scidb_prepare”:

ubuntu@dfz-scidb-0:~/scidb$ ./deployment/deploy.sh scidb_prepare ubuntu “” mydb mydb mydb /home/ubuntu/mydb-DB 2 default 1 default dfz-scidb-0 dfz-scidb-1

I got this error:

scidb.py: ERROR: (REMOTE) Remote command exceptions:
Abnormal return code: 1 stderr:

Here’s the error from dfz-scidb-1:~/mydb-DB/1/0/scidb.log

2016-07-29 05:46:32,957 [0x7f81c5ac3800] [DEBUG]: _makeCredentials: Search for 'dfz-scidb-0:5432:mydb:mydb:'
2016-07-29 05:46:32,970 [0x7f81c5ac3800] [ERROR]: System catalog connection failed: SystemException in file: src/system/catalog/SystemCatalog.cpp function: connect line: 2605
Error id: scidb::SCIDB_SE_SYSCAT::SCIDB_LE_CANT_CONNECT_PG
Error description: System catalog error. Cannot connect to PostgreSQL catalog: ‘FATAL: no pg_hba.conf entry for host “172.31.9.92”, user “mydb”, database “mydb”, SSL on
FATAL: no pg_hba.conf entry for host “172.31.9.92”, user “mydb”, database “mydb”, SSL off
’.

Any ideas?


#3

solved: need to massage postgresql a bit.