14.7 cluster: initall not working, deprecation warnings


#1

I have been struggling to upgrade to SciDB 14.7 on a cluster (which used to run 13.12) for awhile now, and I’m really unsure of how to proceed at this point.

I tried to use the cluster_install script, but it didn’t work because the non-coordinator machines on the cluster are not connected to the internet (and thus can’t use yum). To get around that, on the coordinator I used yum --downloadonly to grab the rpms for scidb-14.7-all and its dependencies and then manually transferred and installed said rpms on each worker.

After doing that, I tried going back to the coordinator and running initall, but it just returns the following:

/usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability. _warn("Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning) /usr/lib64/python2.6/site-packages/Crypto/Util/randpool.py:40: RandomPool_DeprecationWarning: This application uses RandomPool, which is BROKEN in older releases. See http://www.pycrypto.org/randpool-broken RandomPool_DeprecationWarning) Found 0 scidb processes
That’s all it does; it doesn’t ask me if I want to initialize the database or anything. There is no log file to look at because the directory the log files are supposed to be in (/home/scidb/DB-scidb) is never created.

If I try to run any operation of scidb.py I’m getting those deprication warnings and I can’t figure out why. I know passwordless ssh works and the iptables should be correct as far as I can tell… what might be causing these sorts of errors?